# Table of Contents

## CHAPTER 1 Introduction 1

What is HP Device Manager? 1
- Overview 2

Concepts 4
- The Device Pane 4
- Device Tree 4
- Element 4
- Task Template 4
- Managed Device 5
- OS Tabs 5
- PXE 5
- Repository 5
- Task 5
- Task Pane & Summary Pane 6
- Template Pane 6
- Status Bar 6
- EWF 6
- Agent Mode 6

Getting More Information 7
- The Internet 7
- Technical Support 7
# Table of Contents

About This Manual 7
  Overview of Contents 7
  Terms & Conventions 9

## CHAPTER 2  Installing HP Device Manager 11

Introduction 11
System Requirements 12
  Management Console 12
  Management Server 12
  Management Gateway 13
  Management Agent 13
  Third Party Software 13
  Network Requirements 14
Installing HP Device Manager 16
Configuring DHCP Servers 30
  Management Server Installed Separately to the DHCP Server 30
  Management Server Installed on DHCP Server Machine 30
  Adding DHCP Option 60 and 201 to an ISC DHCP Server 32
  Configuring a Linux DHCP Server 33
Configuring Routers 33
Uninstalling Device Manager 34

## CHAPTER 3  Getting Started 37

Logging in to the HP Management Console 37
Configuring the Repository 39
  Creating an FTP Repository 39
Management Console Overview 43
Client Discovery 45
  HP Management Agent Broadcast 45
  Discover Agent 45
  Discover by DHCP Tag 49
Agent Configuration  49
Adding Elements to the Repository  51
Importing an Element into the Repository  52

CHAPTER 4  Using the HP Management Console  57
Menu Item Overview  57
Toolbar Overview  62
Device Management  64
  Device Tree Icons  65
  Displaying Device Properties  66
  Deleting Devices  67
Discovering Devices  68
Grouping Devices  71
  Dynamic Grouping  71
  Manual Grouping  75
  Naming Grouping Properties  78
  Changing Grouping Properties  79
  Pre-assigning Devices to Groups  80
Editing the Device Filter  81
  Filter Security  85
Searching for a Device in the Device Tree  86
Checking Network Connection Status  87
Printing Information About Devices & Tasks  89
  Printing Device Information  89
  Printing a Device Task Report  90
Shadowing Devices  91
Power Management  93
Task Template Management  94
  Task Template Categories  94
  Creating & Editing Task Templates  95
  Adding a Template to Favorites  96
  Using Template Sequence Templates  96
  Importing & Exporting Task Templates  97
Task Management  98
Table of Contents

Task Pane Icons 98
Applying Tasks to Devices 99
Displaying Task Properties 102
Configuring Task Parameters 103
Pausing Tasks 105
Continuing Tasks 106
Resending Tasks 106
Deleting Tasks 107
Displaying Task Logs 107
Opening VNC Viewer for Shadowing 108
Opening a Result Template 108
Device Status Tools 109
Status Walker 109
Status Snapshot 114

CHAPTER 5 Common Tasks 117
Performing a Task 117
Changing Connection Settings 119
Changing Device Settings 122
  Configuring Network Settings 122
  Configuring Display Settings 123
  Configuring Time Settings 124
  Configuring Write Filter Settings 125
Using File and Registry Templates 127
  Merging File and Registry Templates 130
Copying Files 131
Remote Command Execution 134
  Remote Execution of Windows Scripts 136

CHAPTER 6 Advanced Tasks 137
Snapins 137
  Introduction 137
  Applying a Snapin to a Thin Client 138
Images 145
Table of Contents

Introduction 145
Images & Repository Management 145
Client BIOS Settings for PXE 146
Pulling a PXE Image From a Client 147
Pushing a PXE Image to a Client 150
Preparing an XPe Client for Image Distribution 152
Cloning an XPe Image 153
Updating Images 157
Changing Registry Settings 159
Getting Registry Settings 159
Installing an XPe Software Component 166
  Transferring an XPe Software Component to the FTP Repository 166
  Installing an XPe Software Component on Client Devices 169
Performing a Persistent Write Operation on NeoLinux 4.x Devices 170
Adding Devices Using MAC Addresses 173
Configuring Agents 175
  Setting Agent Parameters 175
  Updating the Agent Version 176

CHAPTER 7 Configuration Management 177
User Management 177
  Working With Users 177
  Working With Groups 180
FTP Repositories 183
  Configuring an FTP Repository 183
  Deleting a Repository 184
  Exporting a Repository 184
  Importing a Repository 185
  FTP Repository Selection for Templates 185
FTP Mappings 186
  Listing Devices & their FTP Servers 186
  Listing Subnets & their FTPs Servers 187
Table of Contents

Filtering Devices or Subnets 188
Grouping Property Name 190
Task Parameters 191
  Valid Time and Timeout 191
  Write Filter Policy Setting 192
Task Settings 193
Status Walker Configuration 194
Licensing 195
  Importing a New License 195
Authentication Management 196
  Key Management 196
  Gateway Access Control 201
Report Management 202
  Adding a Report Template 202
  Importing a Report Plug-in File 206
  Generating a Report Using a Report Template 207
Alias Management 209
  Device Version Alias 209
  Subnet Address Alias 211
  Exporting an Alias 212
  Importing an Alias 212
Template Plugin Management 213
  Importing a Template Plugin 213
  Removing a Template Plugin 214

APPENDIX A  Installing & Running JRE 215
  Introduction 215
  Windows-based Server Installation 215
  Linux-based Server Installation 216

APPENDIX B  Installing & Running MySQL 217
  Installing MySQL on Linux-based Servers 217
  Running MySQL on Linux-based Servers 218
APPENDIX C  Error Code Reference  219
Error Codes  219

Index  239
CHAPTER 1

Introduction

This chapter introduces HP Device Manager and describes the scope of this User Manual.

What is HP Device Manager?

HP Device Manager is a server-based application that provides sophisticated centralized administration capabilities for thin client devices running HP software. Features of HP Device Manager include:

- Centralized management of software configuration and upgrades.
- A central server-based database.
- The ability to easily create, store and update tasks.
- The ability to report on work done and task status.
- The ability to access any file or the system registry in thin client devices.
- XML-based task file.
- Design tool for administrator to create tasks.
- User-friendly graphical user interface.
- Easy and powerful repository management.
- Support for WAN environment.
- Windows® XPe device management.
Introduction

- Easy to change Enhanced Write Filter setting for XPe Agent.
- The ability to adjust the response time.
- Communicate with Data Encryption and Data Compression between HP Management Server and HP Management Gateway.
- Easy to set the work mode of Agent.

Overview

HP Device Manager is structured as a Console - Server - Gateway system.

HP Management Console

The HP Management Console is the user interface of HP Device Manager. Several HP Management Consoles can interact with an HP Management Server. The console allows system administrators to view details for each controlled device, organize device trees, create and maintain remote job definitions, and monitor tasks sent out to devices.
**Introduction**

**HP Management Server**

The HP Management Server controls agents through the HP Management Gateway. Tasks, stored as Task Templates on the server, can be sent to each agent through each agent’s respective gateway to perform commands as required.

**HP Management Gateway**

The HP Management Gateway serves as the link between devices and the HP Management Server. Devices register with the gateway when they are started. The machine installed with the HP Management Gateway also normally contains the PXE Server installed by HP Device Manager.

**Device Agent**

The HP Management Agent is a software component installed on thin client devices so that HP Device Manager can interact with them. Agents are embedded into each HP operating system to enable Device Manager to manage devices out-of-the-box (however, agents on older devices may need to be upgraded). Agents get task commands, execute the commands and report on their status.

**FTP Server**

The FTP server is where files are stored in a repository of components, images, etc. that can be uploaded from or downloaded to the agents at the request of the HP Management Server. You can create a repository on more than one FTP server. The repository on an FTP server is referred to as the "FTP Repository" in dialogs and in this User Manual to distinguish it from the HP Management Server Repository (the "Server Repository").
Introduction

Concepts

The Device Pane
The **Device Pane** is in the top-left of the Management Console’s main screen. All thin clients of a selected product type that are connected to the server are displayed in this pane.

This pane contains the **Device Tree** and the **Grouping Scheme** drop-down menus.

Device Tree
The **Device Tree** is the organized structure of all the managed devices in the Management Console, displayed in the **Device Pane**, on the top-left of the main screen.

The tree contains all the devices reported to the Management Server. Devices can be automatically sorted and grouped according to their attributes, or they can be dragged and dropped into arbitrary groups when the devices are grouped by their customized extended properties.

Tasks can be designated to groups of devices to meet their specific needs.

Element
An **Element** is a type of resource (such as a software component, system image, diagnostic tool or agent file) stored in the **Repository** which can be applied to a device using a particular template.

Task Template
**Task Templates** are some of the tools administrators may use to remotely control the devices. They are displayed in the **Template Pane**. Each Task Template is an XML file that defines the configuration change or software update that administrators want the remote devices to do.

HP Device Manager provides a variety of built-in Task Templates and many examples on how to manage remote devices, including device name changes, network settings, home URL changes, ICA connection clones, add/remove software components and so on.
Task Templates can be imported or exported by using tools on the Management Console. New Task Templates can be downloaded from HP’s FTP site, then imported to your HP Management Server.

**Managed Device**
Managed device, client device, remote device, or device, as mentioned in this manual, means a device managed by HP Device Manager, such as a thin client.

**OS Tabs**
OS Tabs enable you to select the different categories of Platform Operating System that are controlled by HP Device Manager.

**PXE**
PXE is a protocol defined on a foundation of industry-standard Internet protocols and services that are widely deployed in the industry (namely TCP/IP, DHCP, and TFTP).

HP Device Manager utilizes PXE to execute thin-client image extraction and distribution.

**Repository**
The Repository is a collection of elements which may consist of software components, system images, diagnostic tools and agent files stored on one or more FTP servers. The Repository actually resides over several servers, these being the HP Management Server Repository (the "Server Repository") and one or more FTP Server Repositories (the "FTP Repository").

**Task**
A task, or job, is the scheduled action to execute Task Templates to a device or group of devices. To create a task, just drag and drop the desired Task Template from the template pane to a device or a group of devices in the device tree. Once executed, the details of the task will be displayed in the **Task Pane** and the summaries will be displayed in the **Summary Pane**.
Introduction

**Task Pane & Summary Pane**

The **Task Pane** and **Summary Pane** are in the bottom area of the main Management Console window. They display the execution status for each task. If there is more than one device for a listed task, the status of each device will be listed.

**Template Pane**

The **Template Pane** is in the top-right of the Management Console main screen. The templates that are applicable to the listed client devices are listed here.

**Status Bar**

The **Status Bar** is shown at the very bottom of the main Management Console window. Descriptions of various items in HP Device Manager are displayed here when the mouse cursor moves over them; for example, a description of each **Device Pane** icon is displayed when the mouse cursor moves over each icon.

**EWF**

Enhanced Write Filter (EWF) provides the ability to write-protect a run-time image. By redirecting all write requests to either a separate disk partition or RAM, EWF allows the run-time image to maintain the appearance of a writeable run-time image. Additionally, Enhanced Write Filter provides the ability to deploy a run-time image onto read-only media, such as a CD-ROM.

**Agent Mode**

**Agent Mode** is the mode of the Management Agent to acquire tasks from the Management Gateway. Through configurations to the Agent mode, the agent can work at the NAT network without Gateway. The Agent mode can be either Push mode or Pull mode. Push mode means the gateway sends the available task to the agent, and Pull mode means the agent would require the task from the gateway at regular intervals.
Getting More Information

The Internet
Current and archival information about HP products, including the latest software updates, is available at:

http://www.hp.com

In addition, this user manual and other HP documentation are available at the HP web site for browsing or downloading.

Technical Support
For technical support regarding HP products, call HP at +1-610-277-8300 or request support using the form at:

http://www.hp.com/support/support_request.html

About This Manual
This manual explains how to use HP Device Manager version 3.8. Occasionally it will refer to items displayed by client operating systems. For a description of these items, please refer to the User Manual for the type of client operating system being used.

Overview of Contents
This manual is divided into the following chapters and appendices:

Chapter 1: Introduction
Introduces HP Device Manager and describes the scope of this User Manual.

Chapter 2: Installing HP Device Manager
Describes the requirements for running HP Device Manager and how to install it.

Chapter 3: Getting Started
Describes how to start using the HP Management Console, set up a repository, and discover clients.
Introduction

**Chapter 4: Using the HP Management Console**
Covers the main functions of the Management Console, including device management, task templates and task management.

**Chapter 5: Common Tasks**
Describes how to use the Management Console to change device settings, copy files and execute commands.

**Chapter 6: Advanced Tasks**
Describes how to use snapins, images, change registry settings, install XPe software components, and set the agent mode.

**Chapter 7: Configuration Management**
Explains the administration of the console, working with users, advanced server configuration, and licensing.

**Appendix A: Installing & Running JRE**
Describes how to install and run the Java® Runtime Environment.

**Appendix B: Installing & Running MySQL**
Describes how to install and run MySQL.

**Appendix C: Error Code Reference**
Explains the meaning of error codes which may be generated by HP Device Manager.
The following terms and conventions are used in this manual:

**devices, clients and thin clients**
The terms "devices", "clients", "thin clients" are interchangeable and refer to any client devices that are running HP software.

**keys to press**
When you need to press two or more keys together at the same time, such as the Ctrl key and the C key, this will be indicated by a plus character inbetween the key names, which will be highlighted. For example: Ctrl + C. The "+" character does not represent a key to be pressed.

**double-click**
To "double-click" means to click the left mouse button twice in quick succession when the mouse pointer is on a particular item on the display, such as an icon. You should use the left mouse button unless specifically told otherwise.

**drag**
To "drag" means to position the mouse pointer on an item on the display (such as the edge of a window), then hold down the left mouse button and move the mouse while keeping the button held down.
Introduction
CHAPTER 2

Installing HP Device Manager

This chapter describes the requirements for running HP Device Manager and how to install it.

Introduction

HP Device Manager consists of four modules:

- **Management Console**
  The graphical application used by administrators to access the management system.

- **Management Server**
  The central server which consolidates and controls all management activities.

- **Management Gateway**
  The gateway which serves as the link between Agents and the Management Server.

- **Management Agent**
  Software installed on the client to enable device management.

The Management Console, Management Server and Management Gateway may be installed on the same machine, or on different machines separately.
The **Management Console** can be installed on any number of machines. It has the following minimum system requirements:

- **Operating System**
  - Windows 2000 Professional (SP4)
  - Windows 2000 Server (SP4)
  - Windows XP Professional (SP2)
  - Windows 2003 Server

- **Third-party Software**
  - Java™ Runtime: SUN Java Runtime Environment version 1.4.2.

- **Hardware**
  - Pentium-III or greater
  - 512MB RAM
  - 256MB free disk space.

The **Management Server** should be installed on a single machine. It has the following minimum system requirements:

- **Operating System**
  - Windows 2000 Server (SP4)
  - Windows 2003 Server

- **Third-party Software**
  - Java Runtime:
    - SUN Java Runtime Environment version 1.4.2.
  - DBMS - any of the following are supported:
    - Microsoft SQL Server 2000
    - MySQL 4.1
    - Microsoft Access 2000 or later.

- **Hardware**
  - Pentium® III or greater
  - 512 MB RAM
  - 512 MB free disk space.
Management Gateway

The Management Gateway may be installed on multiple machines. However, only one Gateway should be present on a subnet. It has the following minimum system requirements:

- **Operating System**
  - Windows 2000 Professional (SP4)
  - Windows 2000 Server (SP4)
  - Windows 2003 Server

- **Third-party Software**
  - N/A

- **Hardware**
  - Pentium-III or greater
  - 512 MB RAM
  - 512 MB free disk space.

Management Agent

The Management Agent should be installed on each device that will be managed by the system. It has the following minimum system requirements:

- **Operating System**
  - NeoLinux 4.0.1
  - Neoware CE 8.1
  - Neoware XP embedded 1.4.2 or later
  - NeoLinux 3

- **Hardware**
  - Thin-client device supporting one of the operating systems listed above.
  - 2 MB free disk space.

Third Party Software

The following FTP Servers are recommended for use with HP Device Manager:

- **FTP Server**
  - Microsoft Internet Information Server (IIS) 5.0
  - Rhinosoft Serv-U FTP Server 4.0
  - SCO UNIX OpenServer FTP Server 5.0.4 or 5.0.6.
Installing HP Device Manager

**Network Requirements**

The network should not contain any other running PXE servers. It should permit free communication on ports used by HP Device Manager. A number of UDP and TCP ports are required for client/server communication. See Table 1 for a list of standard ports required, and Table 2 for a list of custom ports required.

If you are using a Server behind a firewall, please add ports 1099 and 40002 to the exception ports in the firewall settings.

**Table 1: Standard Ports Required**

<table>
<thead>
<tr>
<th>Port</th>
<th>Protocol</th>
<th>Purpose</th>
</tr>
</thead>
<tbody>
<tr>
<td>67 &amp; 68</td>
<td>UDP</td>
<td>PXE - Bootstrap.</td>
</tr>
<tr>
<td>69</td>
<td>UDP</td>
<td>TFTP (Trivial File Transfer Protocol).</td>
</tr>
<tr>
<td>4011</td>
<td>UDP</td>
<td>DHCP Proxy Service (this is an alternative to ports 67 and 68 if those ports are not available).</td>
</tr>
<tr>
<td>20 &amp; 21</td>
<td>TCP</td>
<td>FTP (used for the Repository).</td>
</tr>
<tr>
<td>5900</td>
<td>TCP</td>
<td>VNC Server.</td>
</tr>
</tbody>
</table>

**Table 2: Custom HP Device Manager Ports Required**

<table>
<thead>
<tr>
<th>Receiver Port</th>
<th>Sender</th>
<th>Receiver</th>
<th>Protocol</th>
<th>Purpose</th>
</tr>
</thead>
<tbody>
<tr>
<td>1099</td>
<td>Console</td>
<td>Server</td>
<td>TCP</td>
<td>Console queries the RMI Registry.</td>
</tr>
<tr>
<td>40000</td>
<td>Server/Agent</td>
<td>Gateway</td>
<td>UDP</td>
<td>Server/Agent polls Gateway.</td>
</tr>
<tr>
<td>40001</td>
<td>Gateway</td>
<td>Agent</td>
<td>TCP</td>
<td>Gateway sends task to Agent.</td>
</tr>
<tr>
<td>40002</td>
<td>Console</td>
<td>Server</td>
<td>TCP</td>
<td>Console calls the remote objects on Server by RMI.</td>
</tr>
<tr>
<td>40003</td>
<td>Server/Agent</td>
<td>Gateway</td>
<td>TCP</td>
<td>Server sends task to Gateway; Agent sends report to Gateway.</td>
</tr>
</tbody>
</table>
Table 2: Custom HP Device Manager Ports Required

<table>
<thead>
<tr>
<th>Receiver Port</th>
<th>Sender</th>
<th>Receiver</th>
<th>Protocol</th>
<th>Purpose</th>
</tr>
</thead>
<tbody>
<tr>
<td>40005</td>
<td>Gateway</td>
<td>Server</td>
<td>TCP</td>
<td>Gateway sends report to Server.</td>
</tr>
</tbody>
</table>
Installing HP Device Manager

The installation program will determine if the software required to run Device Manager is already installed.

*Note: Different operating systems may have slightly different steps and wording for the installation process.*

1. Run the Device Manager InstallShield Wizard. The installation’s introductory dialog will be displayed.

2. Click **Next**.

3. Read then accept all the terms in the **License Agreement** dialog by clicking **Yes**.
4 Read the **System Requirement** then click **Next**.

5 In the **Choose Destination Location** dialog, select the folder where Device Manager will be installed. Accept the default folder or click **Browse** and navigate to a specific location.
6. Click **Next** and select a **Setup Type**.

**Typical** - The Management Console, Server and Gateway will be installed with their default configurations. A Microsoft Access database will be initialized as the Server’s database.

**Compact** - Only the Management Console will be installed.
Installing HP Device Manager

**Custom** - Select the components to install and specify the configuration of each one:

- **Console** - Does not require any configuration.
- **Server** - You can choose which database will be used for the Server. The optional databases are Microsoft Access, MySQL and Microsoft SQL Server.
- **Gateway** - You should configure DHCP and Gateway settings. The DHCP server is used by the PXE boot ROM to get an IP address as well as other basic networking information (subnet mask, default gateway, etc.).

7 Select **Custom** as an example, then click **Next** to continue.

8 Select the Device Manager components that you wish to install then click **Next** to continue.
Installing HP Device Manager

A Java Runtime Environment of version 1.4 or later, including any Java2 platform system, is required to run Device Manager. If JRE is not installed on your machine or its version is older than 1.4, the system will display the following dialog:

9  In the **Select Program Folder** dialog, select the name of the folder to store HP Device Manager.
10 Click **Next** to preview the current installation settings.

11 Click **Next** to start installing the selected HP Device Manager component(s).
12 Please wait until the file copying process is finished.

13 Click **Next** and the **DHCP Configuration** dialog will appear.

Specify whether the DHCP server is located on the machine you are installing HP Device Manager.
Note: The DHCP server may need to be configured so that it can be used with Device Manager, particularly if it is on the same machine as Device Manager. See “Configuring DHCP Servers” on page 30 for further information.

14 Click Next to install the Management Server and Management Gateway services to your machine.
15 Click **Next** to display the **Gateway Configuration** dialog.

![Gateway Configuration Dialog](image)

The **Management Server Address** is the address for the Management Server that the Management Gateway will report to.

The **Local NIC** selects which NIC the gateway will receive agent reports on. If there is only one NIC for the system, this field can be left blank.

The **Start PXE service when Gateway is started** setting determines whether the PXE service will be started along with the Management Gateway. The PXE service is always installed along with the Gateway, but can be controlled independently of the Gateway (by changing this setting to **NO**) if required. If this is set to **YES**, when the Gateway is stopped, the PXE service will also stop; when the Gateway is started, the PXE service will also start.
16 Once you have set up the Gateway, click **OK** to save the settings and continue.

17 Click **Next** to start the Management Server Database configuration.

18 Select one database installation option and click **Next** to start the configuration.
Create new database:

Note: If a Database named ndmdb already exists, it will be overwritten without any warning!

Use Device Manager database at existing location:

Select the folder where Device Manager has been installed. Input the path or click Browse and navigate to a specific location in the Directory Settings box.
Migrate Device Manager database to new location:

Select the folder where Device Manager has been installed. Input the path or click **Browse** and navigate to a specific location in the **Directory Settings** box.

19 The following dialog will appear when the database has been successfully created.

20 Click **OK** to set the Administrator password.
21 Click **OK** and you will be informed that the password has been set successfully.

22 Click **OK**.

23 Click **Next**.
24 Click **Finish** to complete the installation process.

25 If the Management Console, Server and Gateway are setup successfully, icons of the Server and Gateway will be displayed in the Systray of your machine as shown below.

![Gateway Icon](image)

A green icon indicates the service is running, a yellow icon indicates the service is starting up, and a red icon indicates the service has stopped.

**Note:** You can start/stop services and configure the Gateway server again by using the menu options displayed when you right-click on the Systray icons.

An icon for the Management Console will be displayed on the desktop.
Configuring DHCP Servers

This section describes how to configure the DHCP server for use with PXE.

Should problems occur when using PXE, the DHCP servers may need to be checked for certain settings that may conflict with PXE. However, on most networks, these issues should not occur.

The DHCP server is used by the PXE boot ROM to get an IP address as well as other basic networking information (subnet mask, default gateway, etc.).

*Note:* The network must be configured using DHCP to use the PXE service.

### Configuring the DHCP Server

1. Ensure the DHCP server has not been previously configured for a PXE bootstrap.
2. If the **DHCP options 43 & 60** are set, remove them.

    *Note:* The Device Manager PXE service will detect the DHCP packets sent by any PXE BootROMs and will offer PXE network parameters without disturbing the standard DHCP negotiation process. This is called DHCP Proxy.

    The DHCP server should then be ready to be used with PXE.

### Management Server Installed Separately to the DHCP Server

If Management Server is installed with a DHCP server on the same machine, it requires some manual configuration.

The Management Server installation process installs the **HP PXE Service**. This service provides the PXE remote-imaging function. The service is automatically started and stopped with the operating system.
The DHCP server is used by the PXE boot ROM to get an IP address as well as other basic networking information (subnet mask, default gateway, etc.).

The following instructions assume that:

- The network is already configured using DHCP.
- The DHCP server has not been previously configured for a PXE bootstrap.
- There are no other TFTP servers running on the same network.

Configuring the DHCP Server:

By default options 60 and 201 are not set under Windows 2000. These options will have to be added in order to tell PXE clients where to find the Management Server.

1. If **DHCP option 43** is set, remove it. (This is due to the fact that Management Server is installed on the same machine as the DHCP server.)

2. Add **option 60**, and set value to “**PXEClient**”. If **option 60** does not exist, see the following instructions on setting this option.

   *Either:*
   - From the main Windows menu select **Start > Run**.
   - Enter **Cmd** in the **Open:** field. A Command shell appears.
   - Enter **netsh** then press the **Enter** key.
   - Enter **dhcp** then press the **Enter** key.
   - Enter **server \servername** (using the UNC name for the server).

   *Or:*
   - Enter **server <ip_address>** (using the IP address of the server.). A “**dhcp server >**” prompt appears in the command window.
• Enter **add optiondef 60 (name of your choice) STRING 0** then press the **Enter** key.

• Enter **set optionvalue 60 STRING “PXEClient“** then press the **Enter** key.

• To confirm that the settings are correct, enter **show optionvalue all** then press the **Enter** key.

3 Add **option 201**, and set the value to **“Management_Gateway_IP_Address’ ‘40003’“**

• Type in **add optiondef 201 (name of your choice) STRING 0** then press the **Enter** key.

• Type in **set optionvalue 201 STRING ‘Management_Gateway_IP_Address’ ‘40003’** then press the **Enter** key. (The **Management_Gateway_IP_Address** is the address of the server running the Management Gateway service.)

• To confirm that the settings are correct, type in **show optionvalue all** then press the **Enter** key.

**Note:** When setting **optionvalue 201, ‘Management_Gateway_IP_Address’ ‘40003’** must be written exactly as shown above, including the single quotes and separated by a single space, otherwise errors will occur.

The DHCP server should then be ready to be used with PXE.

**Adding DHCP Option 60 and 201 to an ISC DHCP Server**

If ISC DHCP server 2.0 is in use, it must be updated to ISC DHCP server 3.0 as version 2.0 does not support vendor specific information. For more information, see [HTTP://WWW.ISC.ORG](http://WWW.ISC.ORG).
Configuring a Linux DHCP Server

1. Edit the DHCP server configuration file `/etc/dhcpd.conf`. Add the following lines to the beginning of the file exactly as shown:

   ```
   ddns-update-style ad-hoc;
   Authoritative;
   Option NDM code 201 =string;
   Option vendor-class-identifier "PXEClient";
   Option NDM "Management_Gateway_IP_Address" '40003';
   ```

2. Restart `dhcpd` to use the new configuration.

3. The HP Device Manager config string should be:

   `Management_Gateway_IP_Address` ‘40003’

Configuring Routers

For PXE to function properly, any network that uses DHCP and has multiple subnets should have an IP helper configured in the router between any clients requiring a dynamic IP address and the DHCP server. The router will need to be configured to have an additional IP helper address to point to the Management Gateway.

Example (Cisco Router):

1. Go to `Global Configuration` mode.

2. Type `ip forward-protocol udp 67` and press Enter.

3. Type `ip forward-protocol udp 68` and press Enter.

4. Go to the LAN interface(s) that serves the PXE workstations.

5. Type `ip helper-address <DHCP Server IP address>` and press Enter.

6. Type `ip helper-address <Management Gateway IP address>` and press Enter.

*Note: The above IP addresses should be entered without the `<` or `>` characters.*
Uninstalling Device Manager

1. Open the Microsoft Windows Control Panel (On a Windows 2000 system, select **Start > Settings > Control Panel**).

2. Double-click **Add/Remove Programs**. The **Add/Remove Programs** window will appear.

3. Select **Neoware Device Manager** from the list of currently installed programs.

4. Click **Change/Remove** to activate the Device Manager configuration program.

5. You will be asked to confirm your decision.

   Click **OK** to continue.
6 Once Device Manager has been uninstalled, the computer should be rebooted. Click **Finish** on the **Remove Completed** dialog to reboot the computer, or select **No** before clicking **Finish** if you intend to reboot the computer yourself later.

7 HP Device Manager has now been uninstalled from your system.
CHAPTER 3

Getting Started

This chapter describes how to start using the HP Management Console, set up a repository, and discover clients.

Logging in to the HP Management Console

To launch the HP Management Console:

1. Double-click the Neoware Management Console icon on the Windows desktop.

OR

From the main Windows screen select:

Start > Programs > Neoware > Neoware Device Manager > Neoware Management Console
Getting Started

The **Log in** dialog will appear.

2 Enter the **Server Address** of your network’s HP Management Server. The address can be entered as an IP address or as a machine name. If the console is on the same machine as the HP Management Server, then enter “localhost”.

3 Enter your **Username** and **Password** in their respective fields.

4 Click **OK** to log in to the Console.

Once the username and password are verified, the main window of the HP Management Console appears.

If this is the first time you have logged in the Management Console, the **FTP Repository Wizard** will be displayed.
Configuring the Repository

The HP Management Repository is used to store software components, system images, diagnostic tools and agent files. Each of the individual items stored in the Repository is referred to as an element. Once elements are stored in the Repository, they can be applied to client devices using templates.

The HP Management Repository actually resides over several servers, these being the HP Management Server Repository (the "Server Repository") and one or more FTP Server Repositories (the "FTP Repository"). The Repository Management tool is used to import elements into the Server Repository and then transfer them to the relevant FTP Repository. An element must be transferred to an FTP Repository before it can be applied to clients.

When you log in the HP Device Manager Console for the first time you will be automatically prompted to create an FTP Repository using the FTP Repository Wizard as described below. If you need to create an additional FTP Repository later, you can run the FTP Repository Wizard again by selecting Tools > Configuration from the Console’s menu bar, selecting FTP Repositories in the left-hand tree pane, then clicking the Launch FTP Wizard button in the top-right corner.

Creating an FTP Repository

To create an FTP Repository:

1. If the FTP Repository Wizard is not displayed already, select Tools > Configuration in the Console’s menu bar, select FTP Repositories in the left-hand tree pane, then click the Launch FTP Wizard button in the top-right corner.

The Welcome screen will be displayed.
2 Click Next to display the **FTP Repository Name** screen.

3 Enter a name to identify this FTP Repository in the **FTP Repository Name** field.

4 Click Next to display the **FTP Repository Location** screen.
5 In the **FTP Server Address** field, enter the IP address or hostname of the server on which the FTP Repository is to be created.

Enter the **User Name** and **Password** for the server to enable HP Device Manager to access it. The **User Name** and **Password** must have write permissions for the server.

Enter a **directory on the FTP server** that will be used to store the FTP Repository. When you click **Next**, the **FTP Repository Wizard** will search for the directory, and if an existing FTP Repository is found at that location, it will use it. If an existing FTP Repository is not found, you will be asked if you want to create the directory and FTP Repository as required.
6 When you have entered all of the details for the FTP Repository, click **Next** to create it.

![FTP Repository Wizard](image)

7 Click **Finish** to close the **FTP Repository Wizard**.

The FTP Repository is now ready for you to add elements to it using the **Repository Management** tool as described in the section “Adding Elements to the Repository” on page 51.
Management Console Overview

The Management Console window consists of three panes and a series of tabs which determine their content.

- **OS Tabs**
  Selects the different categories of terminal operating systems that are controlled by HP Device Manager. Note that only the tabs for the operating system types of the devices currently managed by HP Device Manager will be displayed.

- **Device Toolbar**
  Provides tools enabling you to power on/off the client devices, shadow a remote client, send tasks, print device properties, discover an agent, etc. Refer to the section “Toolbar Overview” on page 62 for more information.
Getting Started

- **Device Pane**
  All clients of the selected OS type that are connected to the server are displayed in this window. This pane contains the **Device Tree**, which is hierarchical list of all the client devices, sorted with a custom grouping scheme.

- **Template Toolbar**
  Selects the different options to delete, merge or send templates.

- **Template Pane**
  The templates that are applicable to the listed client devices are listed here.

- **Task Pane**
  Displays the execution status for each task in a hierarchical structure. If there is more than one device for a listed task, the status of each device will be listed.

- **Status Bar**
  Descriptions of various items in the HP Management Console are displayed here when the cursor moves over them.
Client Discovery

Clients which have the HP Management Agent installed must be ‘discovered’ by HP Device Manager before they can be used. There are four approaches to client discovery:

- Through an HP Management Agent Broadcast (automatic)
- Server-side discovery using IP walking
- Discover Agent using DHCP Tag
- Agent Configuration

**HP Management Agent Broadcast**

The HP Management Gateway will normally be able to detect most HP Management Agents. The gateway functions by listening for a network broadcast message sent when each agent starts up. However, to ensure that the gateway is able to detect all agents, it must be running before each agent is started up.

If the gateway is unable to detect an agent, Discover Agent, IP walking, DHCP Tag or Agent Configuration can be used instead.

**Discover Agent**

HP Device Manager can search a range of IP addresses for agents and gateways.

1. Click on the **Discover** button in the **Device Toolbar** and select **Discover Device** in the menu.

The **Discover Device** dialog will be displayed.
Walking with IP Range

2. Select the gateway in the Select Neoware Management Gateway list box, then select the Walking with IP Range option.

3. Click Next to display the Discover by Range dialog.

4. IP scopes define set ranges where HP Device Manager will search for client agents. Select Use Preset IP Scope then select an IP Search Scope, or deselect the box and enter a Starting IP Address and an Ending IP Address. IP walking will search this range of addresses for a reply.

To configure an IP scope, select the Edit... option in the IP Search Scope list box to display the Edit IP Walking Scope dialog.
Select an existing IP scope from the **IP Walking Scopes** list or click **Add** to create a new one.

Enter a scope name to be used by HP Device Manager to refer to the new search scope, then click **OK**.

Define the IP address range you want HP Device Manager to search for client agents by filling in the **Starting IP Address** and **Ending IP Address**. The IP address can be copied from another location and pasted here. Click **Apply** to save the settings, then **OK** to exit.
Walking with IP List

2 Select the gateway in the **Select Neoware Management Gateway** list box, then select the **Walking with IP List** option.

3 Click **Next** to display the **Discover by List** dialog.

4 The IP addresses in the **IP List** can be customized according to your specific needs. Refer to the table below for descriptions of each button in the dialog.

<table>
<thead>
<tr>
<th><strong>Table 3: Discover by List - Button Functions</strong></th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Button</strong></td>
</tr>
<tr>
<td>Add</td>
</tr>
<tr>
<td>Delete</td>
</tr>
<tr>
<td>Import...</td>
</tr>
<tr>
<td>Export...</td>
</tr>
<tr>
<td>Copy</td>
</tr>
<tr>
<td>Paste</td>
</tr>
</tbody>
</table>
5 Click on OK to search for agents or gateways. Once the search has finished, a report will show the clients detected by HP Device Manager.

6 Click Close to automatically add the successful IP addresses to the Device Pane.

**Discover by DHCP Tag**

An agent can automatically register with a gateway based on the content of a DHCP tag it receives during start-up. Add option 202 to DHCP server and set the value to "<Server IP> <Gateway IP>". (The Server IP and Gateway IP is the IP address of the server running the Management Server and Gateway respectively.) Please refer to “Configuring DHCP Servers” on page 30 for details on how to configure DHCP Server and add options.

**Agent Configuration**

You can manually add the IP address of the gateway to the agent's configuration file so that the agent can search for the gateway automatically.

**To Configure Windows XP Embedded Agents:**

1. Open the directory of C:\WINDOWS\xpeagent.

2. Open the Agent.cfg file with the Notepad application.
3 Modify the gateway IP address in the second line. Please take the format of the following illustration as an example (where 192.168.0.106 is the IP address of the gateway).

![Agent.cfg - Notepad](image)

4 Save your modifications and close this file.

When rebooted, the agent will search for the gateway according to your specified IP address in the `Agent.cfg` file.

*Note 1:* The agents in the NAT environment must be configured as described above.

*Note 2:* As for the agents that have successfully finished one task at least, the IP address of the gateway has been added into the original format of the `Agent.cfg` file on these agents. Hence you do not need to manually configure these agents again.
Adding Elements to the Repository

This section describes how elements are added to the HP Management Repository so that they are available for applying to client devices. You must have configured an FTP Repository using the FTP Repository Wizard before you can add elements to it (refer to the section “Configuring the Repository” on page 39 for details).

The HP Management Repository actually resides over several servers, these being the HP Management Server Repository (the "Server Repository") and one or more FTP Server Repositories (the "FTP Repository"). The Repository Management tool is used to import elements into the Server Repository and then transfer them to the relevant FTP Repository. An element must be transferred to an FTP Repository before it can be applied to clients.

*Note*: When importing an element into the HP Management Repository, a relay FTP server must be selected to temporarily hold the element, which is then automatically transferred to the Server Repository.

The Repository Management tool is displayed by selecting Tools > Repository Management from the Management Console’s menu bar. The following section describes how to use it to import an element into the Server Repository, then transfer it to an FTP Repository.

Elements created through the Console using a template (for example, an image file), are placed in the FTP Repository specified in the template. If you want the element to be available in another FTP Repository, you first need to transfer it to the Server Repository using the Repository Management tool’s Download button, then transfer the element from the Server Repository to the other FTP Repository using the Upload button.
Getting Started

Importing an Element into the Repository

The following procedure describes how to import an element into the Repository. In this example we are importing a snapin which can be used to add Adobe Reader to NeoLinux 4 clients.

1. Copy the element to be imported to a temporary location on your local drive. (In this case the element is a snapin downloaded from the support section of the HP website.)

2. Select **Tools > Repository Management** from the Management Console’s menu bar to display the **Repository Management** dialog.

![Repository Management Dialog]

The Repository Management Dialog manages the elements on the Neoware Management Server and FTP servers.

---

52 Adding Elements to the Repository
3 In the **Select an element type to display** field, select the appropriate element option from the drop-down list. For this example we will be using a NeoLinux 4 snapin to install Adobe Acrobat Reader to NeoLinux 4 thin clients, so **NL4 Snapins** is selected.

4 Click the **Add from local file** button to display the **Add Element to Server - Step 1** dialog.
5 Click the ... button in the **Element Path** box to browse to the
directory containing the snapin you downloaded in step 1. Select
the folder containing the snapin files (in our example it is
Adobe_Acrobat_7.0.9-NL4.0.1-6002) then click **Choose**.

![Add Element to Server - Step 1](image)

The **Relay FTP Repository** field will display the name of the FTP
Repository to use for relaying element files. You can change this
if required.

6 Click **Next** to start copying the element files to the relay FTP
Repository.

![Add Element to Server - Step 2](image)

A message box will be displayed once the element files have
been successfully uploaded to the relay FTP Repository.

![Elements Successfully Uploaded to Relay FTP Repository](image)

7 Click **OK** to automatically transfer the element files from the
relay FTP Repository to the Server Repository.
The **Repository Management** dialog should now display the name of the element in the **Elements on Server Repository** field.

8. Select the name of the FTP Repository to which you want to transfer the element from the **Elements on FTP Repository** dropdown list box.

9. Select the element to transfer in the **Elements on Server Repository** field, then click the **Upload** button.

Once the element has been transferred, it will be listed in both the **Server Repository** and **FTP Repository** fields.
Now that the element is in the FTP Repository, it can be applied to client devices using a template.
CHAPTER 4

Using the HP Management Console

This chapter covers the main functions of the Console, including device management, task templates and task management.

Menu Item Overview

The following table provides a brief description of the functions of all the menu items available in the Management Console.

<table>
<thead>
<tr>
<th>Menu</th>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>File</td>
<td>Import License</td>
<td>Import a new license for Device Manager.</td>
</tr>
<tr>
<td></td>
<td>Import Scheme</td>
<td>Import a device grouping scheme.</td>
</tr>
<tr>
<td></td>
<td>Export Scheme</td>
<td>Export a device grouping scheme.</td>
</tr>
<tr>
<td></td>
<td>Print Device Information</td>
<td>Print information about the devices.</td>
</tr>
<tr>
<td></td>
<td>Print Device Task Report</td>
<td>Displays and prints task information on all users or a specific device.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>See “Printing a Device Task Report” on page 90 for more information.</td>
</tr>
<tr>
<td></td>
<td>Print Task Report</td>
<td>Displays and prints information on tasks.</td>
</tr>
<tr>
<td></td>
<td>Exit</td>
<td>Exit the Management Console.</td>
</tr>
</tbody>
</table>
### Table 4: Management Console - Menu Items

<table>
<thead>
<tr>
<th>Menu</th>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>View</strong></td>
<td>Edit Grouping Scheme</td>
<td>Sort the device list using customized properties according to the actual requirements. See “Grouping Devices” on page 71 for more information.</td>
</tr>
<tr>
<td>Search Device Tree</td>
<td>Search Device Tree</td>
<td>Search for a device in the Device Tree according to the IP address, host name and device IDs. This option is very useful in a network containing a large number of devices.</td>
</tr>
<tr>
<td>Device Filter</td>
<td>Device Filter</td>
<td>Configure the device filters so as to filter the devices when the Management Console is sending tasks. As a result, only the required devices can receive and perform the task.</td>
</tr>
<tr>
<td>Refresh</td>
<td>Refresh</td>
<td>Contact the Management Server to refresh the status of the console.</td>
</tr>
<tr>
<td><strong>Tools</strong></td>
<td>Configuration</td>
<td>Configure settings related to FTP servers, IP search scopes, system time-outs, shadowing, gateway polling and extension properties. See “Configuring the Repository” on page 39 for more details.</td>
</tr>
<tr>
<td>User Management</td>
<td>User Management</td>
<td>Configure user accounts and user groups for the console. See “User Management” on page 177 for more information.</td>
</tr>
<tr>
<td>Repository Management</td>
<td>Repository Management</td>
<td>Control the elements (such as images and software components) that are stored on the Management Server repository and the FTP server repositories. See “Configuring the Repository” on page 39 for more details.</td>
</tr>
<tr>
<td>Report Management</td>
<td>Report Management</td>
<td>Manage the reports of the Devices and the Tasks so that the user can get the required reports according to the customized conditions.</td>
</tr>
</tbody>
</table>
### Table 4: Management Console - Menu Items

<table>
<thead>
<tr>
<th>Menu</th>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Authentication</td>
<td>Management</td>
<td>Key Management - Manage the communication keys such as add, update, import and export options, etc.</td>
</tr>
<tr>
<td></td>
<td>Gateway Access Control</td>
<td>Decide if a specified gateway is an authenticated gateway. If not, the gateway will be banned and cannot communicate with the Management Server.</td>
</tr>
<tr>
<td>Status Walker</td>
<td></td>
<td>This tool makes a list of all the IPs available and walks to them; taking back their status information and displaying it.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>See “Status Walker” on page 109 for details.</td>
</tr>
<tr>
<td>Status Snapshot</td>
<td></td>
<td>This tool takes a snapshot, creates a report of the devices’ status and stores it in the server to be displayed when the tool is opened.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>See “Status Snapshot” on page 114 for more information.</td>
</tr>
<tr>
<td>Device</td>
<td>Check</td>
<td>Check the network connection status of the agents via Ping and Trace Route.</td>
</tr>
<tr>
<td></td>
<td>Connection Status</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Add</td>
<td>Add a new device.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>See “Adding Devices Using MAC Addresses” on page 173 for more information.</td>
</tr>
<tr>
<td></td>
<td>Delete</td>
<td>Delete the selected device.</td>
</tr>
<tr>
<td></td>
<td>Manual Group</td>
<td>Add Folder, Rename or Delete.</td>
</tr>
<tr>
<td></td>
<td>Send Task</td>
<td>Send a Task Template task to the selected device.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>See “Applying Tasks to Devices” on page 99 for more information.</td>
</tr>
<tr>
<td></td>
<td>Shadow</td>
<td>Attempts to shadow the selected device.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>See “Shadowing Devices” on page 91 for more information.</td>
</tr>
</tbody>
</table>
Table 4: Management Console - Menu Items

<table>
<thead>
<tr>
<th>Menu</th>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Power Management</td>
<td>Reboot - Sends a command to reboot</td>
<td>Reboot - Sends a command to reboot the selected device.</td>
</tr>
<tr>
<td></td>
<td>the selected device.</td>
<td>Wake on LAN - Sends a command to the selected device to start it up.</td>
</tr>
<tr>
<td></td>
<td>Shutdown - Sends a command to shut</td>
<td>Shutdown - Sends a command to shut down the selected device.</td>
</tr>
<tr>
<td></td>
<td>down the selected device.</td>
<td>See “Power Management” on page 93 for more information.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Get the specific information of the selected device, such as General, Software, Hardware, Hotfix, Network, Configuration and other extended properties, etc.</td>
</tr>
<tr>
<td>Properties</td>
<td>Displays the properties for the</td>
<td>Displays the properties for the selected device.</td>
</tr>
<tr>
<td></td>
<td>selected device.</td>
<td>See “Displaying Device Properties” on page 66 for more information.</td>
</tr>
<tr>
<td>Template</td>
<td>Delete</td>
<td>Remove the selected template.</td>
</tr>
<tr>
<td></td>
<td>Merge</td>
<td>Merge two or more selected composite templates.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>See “Merging File and Registry Templates” on page 130 for more information.</td>
</tr>
<tr>
<td></td>
<td>Send Task</td>
<td>Send the selected template to the devices as a task.</td>
</tr>
<tr>
<td></td>
<td>Properties</td>
<td>Edit the selected template’s properties.</td>
</tr>
<tr>
<td></td>
<td>Add to Favorites</td>
<td>Add the frequently used templates to the Favorites tab in the Template Pane for more convenient usage.</td>
</tr>
<tr>
<td></td>
<td>Import</td>
<td>Import an XML template file into the currently selected template category.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>See “Importing &amp; Exporting Task Templates” on page 97 for more information.</td>
</tr>
</tbody>
</table>
### Table 4: Management Console - Menu Items

<table>
<thead>
<tr>
<th>Menu</th>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Export</td>
<td>Export an XML template file into the currently selected template category. See “Importing &amp; Exporting Task Templates” on page 97 for more information.</td>
<td></td>
</tr>
<tr>
<td>Template Plugin Management</td>
<td>Manage the plugin of the templates, such as import or uninstall plugin, etc.</td>
<td></td>
</tr>
<tr>
<td>Task</td>
<td>Pause</td>
<td>Pause the selected task.</td>
</tr>
<tr>
<td></td>
<td>Continue</td>
<td>Continue the selected task.</td>
</tr>
<tr>
<td></td>
<td>Resend</td>
<td>Resend the selected task.</td>
</tr>
<tr>
<td></td>
<td>Cancel</td>
<td>Cancel the selected task.</td>
</tr>
<tr>
<td></td>
<td>Cancel All</td>
<td>Cancel all tasks.</td>
</tr>
<tr>
<td></td>
<td>Delete</td>
<td>Delete the selected task.</td>
</tr>
<tr>
<td></td>
<td>Delete All</td>
<td>Delete all tasks in the Task Pane.</td>
</tr>
<tr>
<td></td>
<td>Delete All Finished</td>
<td>Delete all finished tasks in the Task Pane.</td>
</tr>
<tr>
<td></td>
<td>Open VNC Viewer for Shadowing</td>
<td>When a remote device has finished the Shadow task, you can login the device via the VNC viewer.</td>
</tr>
<tr>
<td></td>
<td>Open Result Template</td>
<td>View the content of the result template, which is created by certain types of templates on the completion of their tasks.</td>
</tr>
<tr>
<td></td>
<td>View Task Contents</td>
<td>View the specific content of the tasks.</td>
</tr>
<tr>
<td></td>
<td>View Task Log</td>
<td>View the task status log.</td>
</tr>
<tr>
<td>Help</td>
<td>About</td>
<td>Display copyright and licensing information for Device Manager.</td>
</tr>
</tbody>
</table>
Using the HP Management Console

**Toolbar Overview**

The toolbar provides quick access to frequently used tools.

This enables you to **Reboot**, **Wake on LAN** or **Shutdown** the currently selected device(s) in the device tree. Refer to the section “Power Management” on page 93 for details.

This enables you to shadow the selected device. The **Task Editor** dialog will be displayed. Click **OK** to apply the shadowing task to the device. Refer to the section “Shadowing Devices” on page 91 for details.

This will display the **Template Chooser** dialog enabling you to send a template task to the currently selected device(s). Refer to the section “Applying Tasks to Devices” on page 99 for details.

This enables you to print information about the device(s) currently selected in the device tree. Refer to the section “Printing Information About Devices & Tasks” on page 89 for details.

This enables you to discover client devices or gateways on the network. Refer to the section “Discovering Devices” on page 68 for details.

This enables you to find a specific device in the device tree. Refer to the section “Searching for a Device in the Device Tree” on page 86 for details.
The following tools are available in the **Template Pane**:

This will delete the currently selected template. You will be prompted to confirm the action before it is actually deleted.

This will display the **Merge Templates** dialog enabling you to merge two or more **File and Registry** templates. Refer to the section “Merging File and Registry Templates” on page 130 for details.

This will display the **Task Editor** dialog enabling you to send a template task to the currently selected device(s). Refer to the section “Applying Tasks to Devices” on page 99 for details.
Device Management

All thin clients that connect to the server are displayed in the **Device Pane** of the Management Console window. Selecting one of the OS tabs below the menu bar will display all of the clients of the chosen OS type in the **Device Pane**. Double-clicking an item in the **Device Pane** or clicking on a folder icon will expand the device list.

Select one or more devices and then right-click to see a menu of applicable commands.

All of these commands are also available in the **Device** menu which is displayed from the Console’s menu bar.
**Device Tree Icons**

On the **Gateway** tab, a **G** icon indicates a Management Gateway:
- A green **G** icon represents a gateway that is currently active.
- A greyed-out **G** icon represents a gateway that is currently down or disconnected.

On the **OS** tabs, devices are represented by the following icons:
- A folder represents a number of devices that have been grouped together using the grouping schemes function.
- A screen icon with a power symbol over it indicates that currently the status of this device cannot be confirmed because a gateway to the device cannot be found.
- A greyed-out screen icon with an exclamation mark over it indicates the device is currently powered-off.
- A screen icon with a curved arrow over it indicates the device is currently in pull mode.
- A screen icon with a curved arrow and padlock over it indicates the device is currently in pull-lock mode (Enhanced Write Filter is ON).
- A screen icon with a straight arrow over it indicates the device is currently in push mode.
- A screen icon with a straight arrow and padlock over it indicates the device is currently in push-lock mode.
To display the properties of a device:

1. Right-click on the device in the Device Pane.

2. Select Properties from the menu (or double-click any device) to display the Device Properties dialog.

The Device Properties dialog displays the properties of the thin client devices that are connected to the server. The dialog lets you see different types of information.

**Note:** The IP address and MAC address in the device properties dialog can be selected and copied. The selected address will be highlighted, then you can right-click to copy the selected address.
Click the **Grouping** tab to set grouping properties, which are used as grouping criteria. See “Changing Grouping Properties” on page 79 for information on how to rename these grouping properties.

![Grouping Properties](image)

**Note:** To set the grouping properties, you can also right-click a device in the **Task View** and select **Edit Device Properties** in the menu.

**Deleting Devices**

To delete a device:

1. Right-click the device in the **Device Pane**.

2. Select **Delete** from the menu.

   The selected device is removed from the **Device Pane**.
Discovering Devices

The **Discover Devices** option allows Device Manager to search a range of IP addresses for agents and gateways.

To use **Discover Devices**:

1. Click on the **Discover** button in the **Device Toolbar** and select **Discover Device** in the menu opened.

2. Select the corresponding gateway in the **Select Neoware Management Gateway** drop-down menu, then select the **Walking with IP Range** option.
3 Click **Next** to display the **Discover by Range** dialog.

4 Check the **Use Preset IP Scope** box and select an **IP Search Scope**, or deselect the box and enter a **Starting IP Address** and an **Ending IP Address**. IP Walking will search this range of addresses for a reply.

**OR**

You can select the corresponding gateway in the **Select Gateway** drop-down menu, and then select the **Walking with IP List** option. Click **Next** to display the **Discover by List** dialog.
In the **Discover by List** dialog, the IP addresses in the **IP List** can be customized according to your specific needs. See the following table for descriptions of each button in this dialog.

**Table 5: Discover by List - Button Functions**

<table>
<thead>
<tr>
<th>Button</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>Add</td>
<td>Add a new IP address to the IP list.</td>
</tr>
<tr>
<td>Delete</td>
<td>Remove an existing IP address from the IP list.</td>
</tr>
<tr>
<td>Import...</td>
<td>Import a *.txt or *.csv file to the IP list.</td>
</tr>
<tr>
<td>Export...</td>
<td>Export the IP list as a *.txt file.</td>
</tr>
<tr>
<td>Copy</td>
<td>Copy the current IP list.</td>
</tr>
<tr>
<td>Paste</td>
<td>Paste a copied IP address.</td>
</tr>
</tbody>
</table>

5. Click **OK** to search for devices.
Grouping Devices

Grouping devices according to specified criteria makes it easier for administrators to manage them. Devices can be grouped automatically according to any of their properties, or manually assigned to groups in any way that is suitable for your requirements. Note that you can also pre-assign the group to which a device belongs from the device itself by editing its agent configuration settings.

Dynamic Grouping

Dynamic grouping allows you to automatically group devices by specific properties. For example, you could create a grouping scheme that will group all devices by their CPU type or agent version. You can specify more than one grouping property for a group, and you can define up to six customizable grouping properties. Once you have defined the properties associated with a dynamic grouping scheme, all devices with matching properties will automatically be assigned to the relevant group, including any devices added to Device Manager in the future.

Defining a Dynamic Grouping Scheme

1. Display the View menu from the Console’s menu bar and select Edit Grouping Schemes.
Using the HP Management Console

The **Dynamic schema** tab lists existing dynamic grouping schemes and enables you to create or edit a grouping scheme. Two schemes are supplied by default: **default scheme** will group devices by gateway ID, whereas **no scheme** will not group devices but just list every device managed by Device Manager.

2 To create a new dynamic grouping scheme, click **Add**.

3 Enter a name for the new grouping scheme then click **OK**.

4 Select a property by which you want to group devices in the **Candidate Properties** list, then click **Add** to add it to the **Grouping Scheme** list. You can specify more than one property.
Note that there are six customizable grouping properties you can use to group your devices as required.

5 Once you have selected the properties to use, specify the priority of those properties by clicking **Up** or **Down** to move the selected property in the **Grouping Scheme** to a higher or lower grouping priority. Device Manager will group devices using the property with the highest priority in the order list. Other properties in the order list are then considered in turn.

You can remove a selected property from the **Grouping Scheme** list by clicking **Delete**.

<table>
<thead>
<tr>
<th>Properties</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Gateway ID</td>
<td>Group by gateway ID.</td>
</tr>
<tr>
<td>Subnet Address</td>
<td>Group by subnet address.</td>
</tr>
<tr>
<td>Device Status</td>
<td>Group by status (on/off).</td>
</tr>
<tr>
<td>Device Type</td>
<td>Group by product type.</td>
</tr>
<tr>
<td>Device Version</td>
<td>Group by device version.</td>
</tr>
<tr>
<td>Agent Version</td>
<td>Group by agent version.</td>
</tr>
<tr>
<td>Write Filter Enabled</td>
<td>Group by EWF status.</td>
</tr>
<tr>
<td>CPU Type</td>
<td>Group by processor type.</td>
</tr>
<tr>
<td>Time Zone</td>
<td>Group by time zone.</td>
</tr>
<tr>
<td>location (Extension Property 1)</td>
<td>Customizable grouping property.</td>
</tr>
<tr>
<td>dept (Extension Property 2)</td>
<td>Customizable grouping property.</td>
</tr>
<tr>
<td>other (Extension Property 3 - 6)</td>
<td>Customizable grouping property.</td>
</tr>
</tbody>
</table>
6. Click **OK** to create the new grouping scheme.

7. Click the **Group by** button in the **Device Tree** panel and select **Dynamic Group**. The new grouping scheme will be listed and available for selection.

8. Select the new grouping scheme to group all devices managed by Device Manager accordingly.
**Manual Grouping**

You can create grouping schemes in which you manually assign devices to groups in whatever way you require.

**Defining a Manual Grouping Scheme**

1. Display the View menu from the Console’s menu bar, select **Edit Grouping Schemes**, then click on the **Manual schema** tab.

   ![Edit Grouping Schemes](image)

   The **Manual schema** tab lists existing manual grouping schemes and enables you to create or edit a grouping scheme. One scheme is supplied by default: **_global** will not group devices but just list every device managed by Device Manager.

2. To create a new manual grouping scheme, click **Add**.

   ![Create Grouping Scheme](image)

3. Enter a name for the new grouping scheme then click **OK**. The name will appear in the **Existing Schemes** list.
4 Click Close.

5 Click the **Group by** button in the **Device Tree** panel and select **Manual Group**. The new grouping scheme will be listed and available for selection.

6 Select the new manual grouping scheme.

Any organisational changes you now make to the devices and folders listed in the **Device Tree** panel will be saved to this grouping scheme.
7 To create a new folder in which to group devices, right-click in the Device Tree pane and select Manual Group > Add Folder from the pop-up menu.

8 Enter a name for the group folder then click OK.

9 You can now drag-and-drop the names of devices into this group folder within the Device Tree panel.
Using the HP Management Console

Naming Grouping Properties

Grouping properties are used to group devices into a customized order suitable for your organization’s network configuration. These groups provide simple management of devices over different departments or different locations. Each property name can be renamed as required.

To rename grouping properties:

1. Display the **Tools** menu from the Console’s menu bar and select **Configuration**.
2. Select the **Grouping Property Name** item in the left-hand tree pane.
3. Enter the names for the 1st, 2nd, 3rd, 4th, 5th and 6th grouping properties as required.

   **Note:** Changing the name of the properties does not alter the data for each property. The 1st property always remains the 1st property, the 2nd the 2nd, and so on.
4. Click **Apply** to save the settings.
5. Click **OK** to finish.
Changing Grouping Properties

Grouping properties can be set by entering them into the properties window for each device, or assigned by dragging and dropping devices between property groups.

Setting grouping properties:

1. Right-click the device whose properties you wish to view.
2. Select the Grouping tab.
3. Edit the data in each field as required.
4. Click OK when done.

These properties can now be used to categorize your devices using grouping schemes in the Device Pane.
Using the HP Management Console

**Dragging and dropping devices:**
1. Ensure that the device tree has at least one grouping property selected in the grouping scheme.
2. Click on a device, hold down the mouse button then drag the device to another group on the device tree.
   
   *Note: Devices can only be dragged between groups of the same level on the device tree, and groups being dragged between must have a grouping property.*

3. Release the mouse button and the grouping property for the device will be set to that of the group being dropped into. The device will then be re-grouped under the target group.

**Pre-assigning Devices to Groups**

You can pre-assign a device to a specific group using the Agent Configuration dialog on the device itself. On the Group tab, select **Use Static Custom Groups** > **Add Group Name** "Manual Group" and specify a value. Once the device agent has registered with the server, you will see the device placed in the specified pre-assigned group folder if you choose the global manual grouping scheme (click the **Group By** button and select **Manual Group > _global**.)
Editing the Device Filter

To edit the Device Filter:

1. Select **Device Filter**... from the **View** menu.

2. Click **Add...** to display the **Set New Device Filter Name** dialog. You can also click **Delete** and **Edit...** to remove or modify the existing Device Filters.

3. Enter a name for the new device filter (e.g. XPe) and click **OK** to display the **Edit Device Filter** dialog.
4 Click the browse button in the **Edit Criteria** section to open the **Choose Criteria Key** dialog.
5 In the **Candidate Criteria Key List**, select the criteria according to your needs. Click **OK** to return to the **Edit Device Filter** dialog.

6 Click the arrow button in the **Edit Criteria** section to select conditions in the drop-down menus. For example: **Write Filter Status = Enabled**.

7 Click **Add** to add it to the **Criteria List** below. You also can select one of the lists to modify or delete.

8 If multiple filters exist in the **Criteria List**, you can select **Satisfy all criteria** or **Satisfy any criteria**. Then click **Save** to return to the **Device Filter Management** dialog.
9 In the **Device Filter Management** dialog you can edit or remove the selected filter according to your requirements.

10 Click the **Generate Device List...** button to create the filtered device list.

Now the administrator can use the device filters to manage the devices in the network.
Filter Security

You can limit the devices a user can see by assigning a filter to that user as his security filter. The procedure is as follows:

1. Display the **Tools** menu and select **User Management...**

![User Management Dialog](image)

2. Select the name of the user on the **Users** tab, then click **Edit**.

3. Display the **Filter** tab.

4. Select the filter to use in the **Enhanced Filter** drop-down list.

When you log on as that user you will see that only the devices allowed by the selected filter are displayed.
You can quickly display a particular device in the Console’s device tree either by selecting **Device > Search Device Tree** from the menu bar, or by clicking the **Search** button in the toolbar.

The **Search Device** dialog will be displayed.

You can find a device either by entering its IP Address, Host Name, Device ID or Device Serial Number, as specified in the **Find Device By** field. Enter the relevant information in the field below then click **Find**. If the device is found, the console will automatically change the display to show the device in the device tree.
Checking Network Connection Status

You can check the network connection status of a device (i.e. whether it is connected to the network or not).

1. In the **Device Pane**, select one or more devices and right-click them to display a menu.

2. Select **Check Connection Status**.

3. Select the utility you want to use to check the connection status of the device. You can choose from:

   **Ping** - A basic Internet program that lets you verify that a particular Internet address exists and can accept requests. Pinging is diagnostically used to ensure that a host computer, which you are trying to reach, actually operates.

   **Trace Route** - This diagnostic tool determines the path taken to a destination by sending ICMP Echo Request messages with varying Time to Live (TTL) values to the destination. Each router along the path is required to decrement the TTL in an IP packet by at least 1 before forwarding it. Effectively, the TTL is a max-
 Using the HP Management Console

imum link counter. When the TTL on a packet reaches 0, the router is expected to return an ICMP Time Exceeded message to the source computer.

A window displaying the network connection status of the device will appear.

4 Click Close.
To print information about any devices listed in the Console:

1. In the **Device Pane**, select the devices you want to print (CTRL-click and/or SHIFT-click them).

2. Click the **Print** icon in the toolbar to display the **Print Device** window. Information about all the selected devices is displayed in the window.

3. Either click **Export** to export the list to a *.csv file.

   Enter a name and click **Save**.
Using the HP Management Console

OR

Click **Print Preview** to print the device report. The **Print Preview** window opens.

4 If you are satisfied with the preview, click the printer icon or display the **File** menu and select **Print**. Click **OK** if you accept the printing settings.

**Printing a Device Task Report**

To print information about tasks:

1 In the **Device Pane**, select one device ONLY.

2 Right-click on it and select **Device Task Report** from the menu.

3 Tick **Tasks from all users** or **Tasks from current users** depending on what information you need to print.

4 Define the period you want to get login information for by clicking the buttons for both **Starting Date** and **Ending Date**.

5 Click **Next** then **Print**.
Shadowing Devices

Shadowing enables you to connect to a remote thin client and view and control that client from the HP Management Console. This can be achieved either by using the **Shadow Device** template available on the **Operations** tab, or by selecting from the pop-up menu when you right-click on a device as described below.

**To shadow a device:**

1. Select a device or a group of devices in the **Device Pane**.
2. Right-click and select **Shadow** from the pop-up menu. The **Task Editor** dialog will be displayed.

3. Click **OK**. When the Shadow processing task is complete, the remote desktop of the terminal will be displayed in a separate window.
Using the HP Management Console

**Note:** The session password of Shadow is the default password, which can be set in Configuration.

To Open VNC Viewer for Shadowing:

1. Select a completed **Shadow Device** task in the **Task Pane**.
2. Right-click and select **Open VNC Viewer for Shadowing**, or display the **Task** menu and select **Open VNC Viewer for Shadowing**.

The remote desktop of the client will be displayed in a separate window ready for your operations.
Power Management

The Management Console enables you to reboot, shutdown and wake a client remotely. This can be achieved either by using the templates available on the Operations tab, or by selecting from the pop-up menu when you right-click on a device as described below.

Note: To wake a client, the Wake On LAN support of the client’s BIOS must be enabled.

To shutdown, reboot, or wake a client:

1. Select a device from the Device Pane in the main Console window.

2. Right-click and select Power Management > Reboot, Wake On LAN or Shutdown from the pop-up menu.

3. The Task Editor dialog will be displayed. Click OK to perform the task.

When the client receives the task, a warning dialog will appear on the screen of the client device to inform the user that the device will be shutdown or restarted.

Power Management
HP Device Manager uses Task Templates as the vehicle of communication between the server and agents residing on thin client devices. A Task Template is an XML file that contains information about a task. XML is a standard data format that can be shared easily across applications and platforms - especially between those on separate operating systems that need to share data.

All the Task Templates in the system are displayed and managed in the **Template Pane**.

![Template Pane Image](image)

**Task Template Categories**

Task Templates are sorted into categories according to their function.

- **Favorites**
  Used to store frequently used templates for convenient access.

- **File and Registry**
  A generic template, consisting of a customizable combination of copying files, deleting files, registry changes, running operating system commands and pauses.

- **Connections**
  Used to get the connection settings of a device.

- **Agent**
  Used to define the work mode of the agent (push or pull), and update the agent version.
Using the HP Management Console

- **Imaging**
  Used to push or pull flash-memory images of client devices.

- **Operations**
  Used to perform various operations on a device such as reboot, shadow, shutdown and wake up.

- **Settings**
  Used to change various settings on the device such as display, network, time and write filter.

- **Software Update**
  Used to install or uninstall software components on client devices.

- **Template Sequence**
  Used to define sequences in which tasks are performed.

Personalized Task Templates, based upon these categories, can be edited, deleted, imported or exported to create customized specific tasks for devices.

### Creating & Editing Task Templates

A set of standard 'blank' task templates are provided which are listed under various categories according to their function in the **Template Pane**. The names of standard templates begin with the "_" (underscore) character, for example: _File and Registry_.

To create or edit a task template:

1. Double-click an existing template in the **Template Pane**, or right-click a template then select **Properties** from the pop-up menu.

2. Specify your requirements for the template using the options available. To clear a value of the target device, leave the corresponding field for that value blank on the template.

3. When you have finished defining a new template, click the **Save as** button and enter a name for the new template.

4. Click **OK**. The new template will be created and its name will appear in the **Template Pane**.
Adding a Template to Favorites

To make it easier to locate templates that are used frequently, you can add them to the Favorites tab as follows:

1. Select a tab from the Template Pane.
2. Right-click on the name of the template in the tab.
3. Select Add to Favorites from the pop-up menu.

A copy of the selected template is added to Favorites.

Using Template Sequence Templates

You can specify two or more templates to be performed in a specific order using Template Sequence templates. A Template Sequence template can contain a maximum of 22 tasks.

1. Select the Template Sequence tab in the Template Pane.
2. Double-click the standard Template Sequence template to open the Template Editor.
3. Click the Add button and select a template to add to the sequence from the pop-up menu. The Template Editor for the selected template will be displayed allowing you to edit it.

   Note: You can define new templates to add to the sequence as required, just select the blank template type from the menu.

4. Click OK to add the template to the template sequence.
5. Continue adding templates to the sequence as required. Note that clicking Add after the first template has been added to the sequence will display an additional menu for you to indicate whether the next template will be actioned after the previous template task has been successful, failed, or anyway (regardless of the result).
6. When you have finished defining the template sequence, click Save as... to save the Template Sequence template for later use.
You can import or export Task Templates so they can be shared between HP Device Manager systems.

**To import an XML file as a Task Template:**

1. Select the **Product Type** tab and the **Category** tab into which you want to import the template.
2. Display the **Template** menu from the menu bar and select **Import**. The **Open** dialog will be displayed.
3. Select the XML file that you want to import.
4. Click **Select Import Files**. The file will be added to the selected tab as a new template.

**To export a Task Template as an XML file:**

1. Display the **Template** menu from the menu bar and select **Export**.
2. Enter the name of the template.
3. Select the destination of the exported file.
4. Click **OK** to export the template as an XML file.
Task Management

All the tasks that have been sent are monitored and the results are displayed in the **Task Pane**. The **Task Pane** lists all the tasks that have been sent to devices.

The task list consists of six columns:

- **Task Name**
  Indicates how many devices that task was assigned to.

- **Status**
  Indicates the status of the task in a particular device.

- **Error Code**
  If the status is waiting and the server is retrying to send the task, this indicates what the problem was.

- **Start Time**
  Indicates when the task was begun.

- **End Time**
  Indicates when the task ended.

- **Progress**
  Indicates the progress of a task in a device.

**Task Pane Icons**

The meaning of the icons displayed in the **Task Pane** are as follows:

**Task Folder**
This groups together a number of devices that have been sent the same task.
Success
The task was executed successfully by the device.

Sending
The console has sent the task to the device and is waiting for a reply.

Failed / Timeout
The task has failed or timed out. (If the task is not complete after finite time, the status of the task will be displayed as Timeout. The error code of the status is 0.)

Ready
The task is executed and waiting for the user’s operation.

Paused
The task has been paused.

Waiting
The task has been scheduled for sending at a later time, and has not been sent yet.

Processing
The task has been accepted by the device and is being processed.

Applying Tasks to Devices
You can apply a task to a device from a defined template for the purpose of remote configuration, monitoring, installing or restricting. Assigning a PXE task will cause the thin client to either wake on LAN or re-boot.

You can apply tasks by drag-and-drop or by manually selecting the task.

1 Drag a template from the Template Pane and drop it on to a device,

OR

Right-click the device and select Send Task from the pop-up menu to display the Template Chooser. Select a category then a template from the templates list, then click Next.
2. The **Task Editor** dialog will be displayed. This enables you to make changes to the template and specify how and when the task is to be performed.
3 The **Content** tab allows you to change the properties of the task as desired. (See “Creating & Editing Task Templates” on page 95 for details.)

4 Select the **Schedule & Batch Control** tab and specify when and how the task is to be performed.

![Task Editor](image)

If you do not select the **Schedule Task** option and specify a time, the task will be sent to the device as soon as you click the **OK** button.

5 Click **OK** to apply the task to the device.
Using the HP Management Console

Displaying Task Properties

To display the properties of a task:

1. In the Task Pane, click the + box next to the Task Name to list the devices that the task is assigned to.

2. Right-click a device and select View Task Contents in the pop-up menu. A Task Contents window will be displayed showing detailed information about the assigned task.

![Task Contents Window](image-url)
Configuring Task Parameters

Select **Tools > Configuration** from the Console’s menu bar to open the **Configuration Management** dialog, then click the **Task Parameters** option in the option tree pane to expand it.

The **Task Parameters** option consists of two sub-options: **Valid Time and Timeout** and **Write Filter Policy Setting**. These are described in the following sections.

**Valid Time and Timeout**

The **Valid Time and Timeout** options enable you to set the duration HP Device Manager will wait for the execution of tasks. You can also specify the start and end time of working hours during which HP Device Manager will not execute tasks. Clicking in an option field will cause the **Description** box to display a short description of that option.

1. Select **Valid Time and Timeout** in the option tree pane of the **Configuration Management** dialog.

2. Set the time, in minutes, for each category: **Valid Time, General Timeout, General Batch Interval, PXE Batch Interval** and **FTP Batch Interval**.
Set the amount, in devices, for each category: **General Batch Amount**, **PXE Batch Amount** and **FTP Batch Amount**.

Check the **Exclude Working Hours** option box to input the start and end time of working hours.

Clicking **Restore defaults** will reset the timeout settings to their defaults and set the working hours to 9.00 start and 17.00 end.

3. Click **Apply** to save the new settings.
4. Click **OK** to exit.

**Write Filter Policy Setting**

The **Write Filter Policy Setting** options enable you to specify how the Enhanced Write Filter on XPe devices affects tasks.

1. Select **Write Filter Policy Setting** in the option tree pane of the **Configuration Management** dialog.
2. Choose one of the three policy items.
3  Click **Apply** to save the new settings.

4  Click **OK** to exit.

---

**Pausing Tasks**

To pause a waiting task:

1  Select a waiting task in the **Task Pane**.

2  Right-click and select **Pause** from the pop-up menu.

The status of the waiting task will be changed to **Paused**.
Using the HP Management Console

**Note: This operation only is available for waiting tasks.**

**Continuing Tasks**

To continue a paused task:

1. Select a paused task in the **Task Pane**.
2. Right-click and select **Continue** from the pop-up menu.

The status of the paused task will be changed to **Waiting**.

*Note: Only paused tasks (tasks that have not been sent) can be continued.*

**Resending Tasks**

If a task has finished, you can resend the task to the device.

1. Select the finished task in the **Task Pane**.
2. Right-click and select **Resend** from the pop-up menu.
Deleting Tasks

To delete a selected task, right-click the task and select **Delete** from the pop-up menu. If you select **Delete All**, all the tasks in the **Task Pane** will be deleted. If you select **Delete All Finished**, all finished tasks will be removed from the **Task Pane**.

**Warning**: Deleting a task that is in progress may damage the OS image! For example, updating and upgrading tasks, pushing imaging tasks, and so on.

Displaying Task Logs

To display the log of a task:

1. Right-click a task in the **Task Pane** and select **View Task Log** from the pop-up menu. A **Task Log** window will be displayed.

2. Click **Close** to close the log viewer when you have finished.

---

Task Management 107
Opening VNC Viewer for Shadowing

You can open a VNC Viewer for shadowing a device by right-clicking a ready or finished shadowing task and selecting **Open VNC Viewer for Shadowing** from the pop-up menu.

Opening a Result Template

Right-click a ready task and select **Open Results Template** from the menu to open the results of some tasks such as **Get Registry**, **Get Connection Configuration** and so on.
Device Status Tools

HP Device Manager has two integrated tools that monitor and record the performance of the devices: Status Walker and Status Snapshot.

**Status Walker**

The Status Walker tool makes a list of all the IPs available and walks to them; it brings back their status information and displays it. This status report is made in real time. The information is stored in a database placed on the server.

*Note: The Status Walker option is only available for Windows gateways.*

1. Display the Tools menu from the Console’s menu bar and select **Status Walker** to display the following dialog.

2. Click **Add** to create a new walking schedule, or **Edit** to modify an existing one. The **Schedule Editor** dialog will be displayed.
3 Select the name of the scope to use in the **Walk the Scope** drop-down menu, or select **Edit...** to define a new scope.

Selecting **Edit...** will display the **Scope Management** dialog which enables you to add, edit or remove scopes.

Click the **Add** button and enter a name for the new scope.
Click **OK** to display the **Scope Editor** dialog.

Specify the IP address range in the **Current Item** fields, then click **Add** to add it to the list box on the left. Click **OK** when you have finished defining scopes.

Click **Close** in the **Scope Manager** dialog to return to the **Schedule Editor**. The scope(s) you defined will be listed in the **Walk the scope** field ready for selection.

4. **Select** the **Gateway** to use.

5. **Use** the **Schedule** options to specify the time and frequency of the task.

6. **Click** **OK**.

The results of scheduled walking tasks will be displayed in the **Walking Tasks** pane at the bottom of the **Status Walker** dialog.
Selecting a **Finished** walking task then clicking the **View** button will display the status of devices found.
Configuring the Status Walker

You can configure the **Status Walker** to suit your requirements as follows:

1. Select **Tools > Configuration** from the Console’s menu bar to open the **Configuration Management** window.

2. Select the **Status Walker Configuration** item in the left-hand tree pane.

   ![Configuration Management Window](image)

   **Note:** You can display a short description of each option by clicking in the option field.

3. Enter a value for the **Walking Group Size**.

4. Define a value for **Walking Timeout**.

5. Set the number of **Walking Retry Times**.

6. Configure the **1st**, **2nd** and **3rd Telnet** by typing in a **Username** and **Password** for each one of them.

7. Click **Apply** to save the settings.

8. Click **OK**.
Status Snapshot

The Status Snapshot tool takes a snapshot of the network, that is, it creates a report of the devices’ status and stores it on the server to be displayed when the tool is opened. This tool does not work in real time. The Status Snapshot settings allow the administrator to schedule the walk and set the frequency.

1. Display the Tools menu from the Console’s menu bar and select Status Snapshot. The Status Snapshot dialog will be displayed.

2. Click Add to create a new status snapshot schedule, or Edit to modify an existing one. The Schedule Editor dialog will be displayed.
3 Schedule the status snapshot task by specifying its **Frequency** and the **Start Time**.

4 Click **OK**.

5 Click **Close**.

The results of the scheduled status snapshot tasks will be displayed in the **Status Snapshot Tasks** pane at the bottom of the **Status Snapshot** dialog.
Selecting a Finished status snapshot task then clicking the View button will display information about the devices found.
CHAPTER 5

Common Tasks

This chapter describes how to use the Management Console to change device settings, copy files and execute commands.

Performing a Task

In order to perform a task on a remote device you must first define a template which provides the instructions to be executed or new settings, then apply that template to the device. The basic procedure is described below. For a more detailed explanation, please refer to the sections “Task Template Management” on page 94 and “Task Management” on page 98.

1. To define a template, double-click an existing template in the Template Pane, or right-click a template then select Properties from the pop-up menu.

2. Specify your requirements for the template using the options available, then click the Save as button and enter a name for the new template.

3. To apply the template to a device or group of devices, either drag the template from the Template Pane and drop it on to the device or group,

   or

   right-click the device and select Send Task from the pop-up menu to display the Template Chooser. Select a category then a template from the templates list, then click Next.
Common Tasks

4  The **Task Editor** dialog will be displayed. Select the **Schedule & Batch Control** tab and specify when and how the task defined in the template is to be performed. If you do not select the **Schedule Task** option and specify a time, the task will be applied to the device as soon as you click the **OK** button.

5  Click **OK** to apply the task to the device.
Changing Connection Settings

HP thin client devices are designed to access servers or applications through pre-defined ICA, RDP, terminal emulation or Web browser connections. HP Device Manager enables you to copy these pre-defined connection settings from one thin client to others of the same model and operating system type.

**Important:** Before copying the connection settings of a device, you must make sure that each connection is properly configured and tested on the network where the connections will be used.

1 Configure a thin client device with the required connection settings and ensure that the connections work on the network where they will be used.

2 Run the Management Console and display the name of the device with the correct connections in the device tree.

3 Select the **Connections** tab in the **Template Pane**, then double-click on the **Get Connection Configuration** template to display the **Template Editor**.

4 Use the check boxes to indicate which connection settings to retrieve from the device.

5 Enter a name for the template which will be created to store the connection settings.
6 Click the **Save as...** button, enter a name for this template then click **OK**.

7 Drag and drop the template on the name of the device with the correct connections in the device tree. The **Task Editor** will be displayed.
8 Click **OK** to apply the task to the client device.

9 The connection settings will be copied from the device and stored in a new template which will appear in the **Templates Pane** with the name you specified in step 5.

10 You can now drag and drop this new template on devices in the device tree to apply the connection settings to them.
Common Tasks

Changing Device Settings

The setup configuration of a device can be changed using templates listed on the **Settings** tab in the **Template Pane**.

<table>
<thead>
<tr>
<th>Task Templates</th>
<th>Description</th>
<th>Base Template Name</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Display Settings</strong></td>
<td>Configure Display Settings</td>
<td>Display Settings</td>
</tr>
<tr>
<td><strong>Network Settings</strong></td>
<td>Configure Network Settings</td>
<td><em>Network Settings</em></td>
</tr>
<tr>
<td><strong>Time Settings</strong></td>
<td>Configure Time settings</td>
<td><em>Time Settings</em></td>
</tr>
<tr>
<td><strong>Write Filter Settings</strong></td>
<td>Configure Write Filter settings</td>
<td><em>Write Filter Settings</em></td>
</tr>
</tbody>
</table>

The following sections provide an overview of each template.

**Configuring Network Settings**

1. Select the **Settings** tab in the **Template Pane**.

2. Double-click the **_Network Settings** template to display the **Template Editor**.

3. Enter the network settings as required.

    **Note:** If **DHCP** is enabled (default), the device will not use static IP information. If you want to use static IP, select **Disable**.
4 Click **Save As...** to save the template with a new name.

5 Drag and drop the template on the device(s) you want to configure.

*Note: Because changes made to device properties can be applied to more than one device at a time, some settings are not available if more than one device is selected. These include the static IP information and device hostname - settings that must be unique to each device.*

**Configuring Display Settings**

1 Select the **Settings** tab in the **Template Pane**.

2 Double-click the **Display Settings** template to display the **Template Editor**.

3 Specify the **Display Resolution** (e.g. 800 x 600) using the slider, and select the screen **Refresh Rate** and **Color Depth** from the drop-down lists.

4 Click **Save as...** to save the template with a new name.
Common Tasks

5 Drag and drop the template on the device(s) you want to configure.

*Note:* The *Color Depth* option is only available for XPe OS devices.

### Configuring Time Settings

1 Select the *Settings* tab in the *Template Pane*.

2 Double-click the *Time Settings* template to display the *Template Editor*.

3 Specify the time settings you require.

4 Click **Save as...** to save the template with a new name.

5 Drag and drop the template on the device(s) you want to configure.
Configuring Write Filter Settings

Note: Write Filter settings are only applicable to XPe OS devices.

1. Select the **Settings** tab in the **Template Pane**.

2. Double-click the **Write Filter Settings** template to display the **Template Editor**.

![Template Editor - Settings](image)

3. Select the drive to configure in the **Drive List** box.

   You can add one or more drives to the list by clicking the **Add Drive** button to display the **Select a Drive** dialog.
Common Tasks

Select a drive letter from the Drives List then click Add to add it to the Added Drives list. Click OK to add the drives.

4 Set the Boot Command to either Enable to set the Write Filter, Disable to remove the Write Filter, or N/ A (No change) to keep the current state for the selected drive.

5 Click Save as... to save the template with a new name.

6 Drag and drop the template on the XPe OS device(s) you want to configure.
Using File and Registry Templates

The _File and Registry_ template is generic in that it consists of a customizable combination of copying files, deleting files, registry changes, running operating-system commands and pauses.

Customizing this template involves adding, deleting and re-arranging a variety of sub-tasks.

1. Select the **File and Registry** tab in the **Template Pane**.
2. Double-click the _File and Registry_ template to display the **Template Editor**.

![Template Editor - File and Registry](image)

3. Click **Add** to add a variety of sub-tasks. (Refer to the table below for more information on each sub-task.)
   - Click **Edit** to edit a sub-task.
   - Click **Delete** to delete the selected sub-task.
   - Click **Up** and **Down** to re-arrange the sub-tasks as required.
4 After modifying the template, click **Save as** to save the template for later use.

**Table 7: File and Registry Template Sub-Tasks**

<table>
<thead>
<tr>
<th>Sub-Task</th>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Copy Files</strong></td>
<td>FTP Server</td>
<td>Select an FTP repository to use.</td>
</tr>
<tr>
<td></td>
<td>Upload</td>
<td>Upload files from the client device to the selected FTP repository.</td>
</tr>
<tr>
<td></td>
<td>Download</td>
<td>Download files from the selected FTP repository to the client device.</td>
</tr>
<tr>
<td></td>
<td>File Path On Console</td>
<td>The path to the files to be copied.</td>
</tr>
<tr>
<td></td>
<td>File Name</td>
<td>The name of the files to be copied.</td>
</tr>
<tr>
<td></td>
<td>Path On Device</td>
<td>The path for the files to be copied to on the device.</td>
</tr>
<tr>
<td></td>
<td>Copy Recursively</td>
<td>Copy files matching the pattern in <strong>File Name</strong> recursively in all subdirectories from the given <strong>Path On Device</strong>.</td>
</tr>
<tr>
<td><strong>Delete Files</strong></td>
<td>File Name</td>
<td>The file name to be deleted.</td>
</tr>
<tr>
<td></td>
<td>Path On Device</td>
<td>The location of the file.</td>
</tr>
<tr>
<td></td>
<td>Delete Recursively</td>
<td>Delete files matching the pattern in <strong>File Name</strong> recursively in all subdirectories from the given <strong>Path On Device</strong>.</td>
</tr>
<tr>
<td><strong>Registry</strong></td>
<td>Add Key...</td>
<td>(Registry tree) Add a key at the selected location on the tree.</td>
</tr>
<tr>
<td></td>
<td>Add Value...</td>
<td>(Registry tree) Add a value on the selected key.</td>
</tr>
<tr>
<td></td>
<td>Rename...</td>
<td>(Registry tree) Rename the selected item.</td>
</tr>
<tr>
<td></td>
<td>Delete</td>
<td>(Registry tree) Delete the selected item.</td>
</tr>
</tbody>
</table>
### Common Tasks

#### Table 7: File and Registry Template Sub-Tasks

<table>
<thead>
<tr>
<th>Sub-Task</th>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Action</td>
<td>(Registry settings)</td>
<td>The action to be applied to the registry table. Set to <strong>add</strong> to add a key, or <strong>delete key</strong> to delete a key.</td>
</tr>
<tr>
<td>Type</td>
<td>(Registry settings)</td>
<td>The type of registry key value.</td>
</tr>
<tr>
<td>Value Name</td>
<td>(Registry settings)</td>
<td>Specify a name for the registry key. Double-click on this field to edit it.</td>
</tr>
<tr>
<td>Value Data</td>
<td>(Registry settings)</td>
<td>Specify the data to add to the registry key value. Double-click on this field to edit it.</td>
</tr>
<tr>
<td>Add Key</td>
<td>(Key settings)</td>
<td>If this is selected, even if the selected key is empty, the key will still be added to the registry.</td>
</tr>
<tr>
<td>Delete Key and Value</td>
<td>(Key settings)</td>
<td>If this is selected, the selected key and all values under it will be deleted. Note that there must be no values under the given key.</td>
</tr>
<tr>
<td>Command</td>
<td>Command</td>
<td>The command on the client device to be executed. Enter the full path name of the command on the client device.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>If you are using a long file name that contains a space, use quoted strings to indicate where the file name ends and the arguments begin. For example: <em>&quot;c:\program files\file.exe&quot;</em>.</td>
</tr>
<tr>
<td>Execute After Reboot</td>
<td></td>
<td>Set to <strong>Yes</strong> if you want the system to reboot and execute the command when it restarts, or <strong>No</strong> if you want the command to be executed immediately.</td>
</tr>
<tr>
<td>Wait</td>
<td></td>
<td>Set to <strong>Yes</strong> if the given command has to wait for the previous command to finish before processing, or set to <strong>No</strong> for simultaneous execution of commands.</td>
</tr>
</tbody>
</table>
Common Tasks

**Table 7: File and Registry Template Sub-Tasks**

<table>
<thead>
<tr>
<th>Sub-Task</th>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Pause</td>
<td>Hours, Minutes, Seconds</td>
<td>The duration of time to pause processing of the template, often in order to wait for certain events, for example a system restart.</td>
</tr>
</tbody>
</table>

**Merging File and Registry Templates**

Two or more File and Registry templates can be merged together to form a new File and Registry template with the combined sub-tasks of all of them.

1. Select one of the File and Registry templates that you wish to merge.

2. Right-click on it and select **Merge** from the pop-up menu.

3. Select another template to merge the selected template with, then click **OK** to merge the templates.

4. You will prompted to enter a name for the new template.

5. Enter a name for the new template.

6. A new File and Registry template will be created with all of the sub-tasks of the original templates combined.
Copying Files

You can copy files from a device to the FTP Repository, or download files from the console to a device through the FTP Repository. Both are achieved using the _File and Registry_ template.

1. Select the **File and Registry** tab in the **Template Pane**.
2. Double-click the _File and Registry_ template to display the **Template Editor**.

3. Click the **Add** button and select **Copy Files**.
4  Click **OK**.

5  Select the **FTP Repository** to use from the list box.

6  Select the **Direction** of the copy files task: **Upload** files from device to FTP Repository, or **Download** files from console to device through the FTP Repository.

7  Specify the **Files to be copied** by clicking in the fields and entering the relevant information. Additional lines can be added by clicking the **Add** button.

   The **File Name** field supports the use of the wildcards * and ?. For example:

   * means zero or more characters.

   ? means one character.

   **com.jar** means the file is named **com.jar**.
c:\abc\*
   c:\abc\
   c:\abc  all mean the same thing, that is, all the files under directory c:\abc\.

   a*       means all the files that start with the letter a.
   *a       means all the files that end with the letter a.

If Copy Recursively is set to Yes, both files and sub-directories matching the wildcard pattern defined in the File Name field will be copied. If No is selected, only files in the given path will be copied, but not sub-directories.

8   Click OK when you have finished specifying files to be copied.

   A Copy Files sub-task will be added to the Sub-Task list of the template.

9   Click Save as... to save the template with a new name.

10  Drag and drop the template on the device you want to copy files to/from.
HP Device Manager can remotely execute commands on a device using **File and Registry** templates. In this context, a command is anything executable on the device’s operating system. It can be applications, DOS batch files, Windows scripts, etc. You can enter any command, however it is recommended that these commands are tested on a client device first.

**Note:** DOS commands cannot be executed directly on a Windows XP Embedded OS. To execute DOS commands you need to write them to a batch file saved with the suffix `.bat`, then execute the batch file.

The Windows environment variable **PATH** may be different on each device, so it is important to enter the full path to each command to make sure it can be found on the device. For example, to execute an executable file named `xxx.exe` in a directory named `C:\Program Files`, enter the command as `C:\Program Files\xxx.exe`

To execute commands:

1. Select the **File and Registry** tab in the Template Pane.
2. Double-click the `_File and Registry_` template to display the Template Editor.
3 Click the **Add** button and select **Command**.

4 Click **OK**.

5 Specify the command to be executed by clicking in the **Command** column and entering the appropriate information.

6 In the **Execute After Reboot** column, select **Yes** if the device should reboot before executing the command you specify. Select **No** if you want the command to execute without the need to reboot the device.
Common Tasks

7 In the **Wait** column, select **Yes** if the given command has to wait for the previous command to finish before processing, or set to **No** for simultaneous execution of commands.

8 If you want to specify more commands, click **Add** to continue.

9 Click **OK** when you have finished.

10 Click **Save As...** to save the template under a new name.

11 Drag and drop the template on the devices where you want the commands to run.

**Remote Execution of Windows Scripts**

Windows Scripting Host is a comprehensive scripting infrastructure for the Microsoft Windows platform, provides script engines, Visual Basic Scripting Edition and Microsoft JScript, which can be embedded into Windows applications and an extensive array of supporting technologies that make it easier for script users to script Windows applications.

For more information on how to write Windows scripts, see:

[http://www.msdn.microsoft.com](http://www.msdn.microsoft.com)

Enter **“windows script”** as search keywords.

To run windows scripts as a command from HP Device Manager, you need to add **“wscript”** before the script name you want to run. **Wscript.exe** is in the **C:\windows\system32** directory.
CHAPTER 6  Advanced Tasks

This chapter describes how to use snapins, images, change registry settings, install XPe software components, and set the agent mode.

Snapins

Introduction

All of HP’s thin client operating systems utilize real filesystems in Flash disk memory instead of monolithic Flash images. They also use registry-based configuration mechanisms. The combination of real filesystems and registry-based configuration allows HP customers to add software or update software modules and device configuration without having to replace the entire Flash image in the thin client device.

Modular software additions and updates need only be as big as they have to be (and in some cases may only be a few kilobytes of information), and registry changes are similarly small. This speeds the update process and helps alleviate bandwidth impact on busy networks and low-bandwidth connections.

HP provides snapins to add software to thin clients, such as Adobe Acrobat Reader. Snapins may also be provided by HP Technical Support to help diagnose customer problems. Customers can develop and use their own snapins, since the technology is based on industry-standard protocols.
Advanced Tasks

Applying a Snapin to a Thin Client

1. Download the required snapin from the support section of the HP website to a temporary location on your local drive.

2. Run the HP Management Console and select **Tools > Repository Management** from the menu bar.

   ![Repository Management](repository_management.png)

   The **Repository Management** dialog will be displayed.
3 In the **Select an element type to display** field, select the appropriate **Snapins** option from the drop-down list. For this example we will be using a NeoLinux 4 snapin to install Adobe Acrobat Reader to NeoLinux 4 thin clients, so **NL4 Snapins** is selected.

4 Click the **Add from local file** button to display the **Add Element to Server - Step 1** dialog.
5. Click the ... button in the **Element Path** box to browse to the directory containing the snapin you downloaded in step 1. Select the folder containing the snapin files (in our example it is *Adobe_Acrobat_7.0.9-NL4.0.1-6002*) then click **Choose**.

The **Relay FTP Repository** field will display the name of the FTP Repository to use for relaying files. You can change this if required.

6. Click **Next** to start copying the snapin files to the relay FTP Repository.

A message box will be displayed once the snapin files have been successfully uploaded to the relay FTP Repository.

7. Click **OK** to automatically transfer the snapin files from the relay FTP Repository to the Server Repository.
The **Repository Management** dialog should now display the name of the snapin in the **Elements on Server Repository** field.

8 Select the name of the FTP Repository to which you want to transfer the snapin from the **Elements on FTP Repository** dropdown list box.

9 Select the snapin to transfer in the **Elements on Server Repository** field, then click the **Upload** button.

Once the snapin has been transferred, it will be listed in both the **Server Repository** and **FTP Repository** fields.
Now that the snapin is in the FTP Repository, it can be applied to client devices using a template.

10 Click Close to exit Repository Management.

11 Click on the OS tab for the operating system supported by the snapin. In our example it is the NeoLinux 4 OS tab.

12 In the Task Templates pane, click the Software Update tab then double-click on the _Snapin template to display the Template Editor.

13 Select the FTP Repository where the snapin resides in the FTP Repository list box.
14 Select the name of the snapin in the **Snapin** list box. The **Action** field will then display actions which can be performed using the snapin. In this case the only action is **Install**.

Note: If the snapin is not displayed in the **Snapin** field, check that you are displaying the **Task Templates pane** in the correct OS tab (**NeoLinux 4** in our example).

15 Click the **Save as...** button and save the template using a name that enables you to easily identify what it does.
Advanced Tasks

The **Task Templates** pane will now display the new snapin template in the **Software Update** tab.

16 To apply the snapin to one or more thin client devices, select the name of the snapin template then drag and drop it on the name of the device(s) in the device tree panel. The **Task Editor** dialog will be displayed.

17 If you want the snapin to be applied to the thin client(s) immediately, click **OK**. Otherwise you can schedule a time for the snapin to be applied by clicking the **Schedule & Batch Control** tab.
Images

Introduction

HP Device Manager can read and write images to and from supported clients. An image file (.img) is a binary file containing all the data on a thin client’s flash storage. HP Device Manager manages images through the Repository Management tool, which also provides utilities to verify image integrity.

The Imaging templates for each OS tab provide various means of reading and writing images depending on whether or not a PXE Server is being used. A PXE image can be pulled from a device and pushed to other devices using the PXE Imaging template (see page 147 and page 150, respectively).

Note: Pushing and pulling images uses the PXE functions of HP Device Manager and some DHCP server setups may conflict with PXE. Should you experience problems with PXE, see “Configuring DHCP Servers” on page 30.

The Update Image template enables you to update a device using an image from a specified FTP Repository without using a PXE Server (see page 157). The Neoware XPe OS tab also includes a Clone XPe Image template (see page 153).

Images & Repository Management

The Repository Management tool enables you to import image files into the Repository and transfer image files between FTP Repositories. It also enables you to sign and verify PXE images. The Repository Management tool is displayed by selecting Tools > Repository Management from the Console’s menu bar. Select the relevant Images option from the Select an element type to display list.

Importing Images

Image files from an external source (i.e. not created from your local HP Device Management System) can be imported into an FTP Repository as described in the section “Importing an Element into the Repository” on page 52.
Transferring Image Files Between Repositories

An image file must be stored in an FTP Repository in order for it to be applied to clients using a template. Image files are initially placed either in the Server Repository if they were imported, or in a specific FTP Repository if created using a template. You can transfer image files between repositories using the Upload and Download buttons in the Repository Management dialog. In order to transfer an image file from one FTP Repository to another, it must first be Downloaded to the Server Repository, then Uploaded from there to the other FTP Repository.

Signing & Verifying PXE Images

If the image file is a PXE image, it can be signed or verified by clicking the Sign or Verify buttons in the Repository Management dialog. HP Device Manager will report a verification error if the MD5 signature file does not exist. Therefore, if the image is from a reliable source, simply click Sign to re-create the digital signature.

Client BIOS Settings for PXE

Before you can pull or push a PXE image, you must make sure that the source and target client devices have their BIOS settings configured correctly.

1. Power-on the thin client device and hold down the Delete key to display the CMOS Setup Utility screen.
2. Select Advanced BIOS Features and set the following:
   - First Boot Device: [LAN]
   - Second Boot Device: [HDD-0]
3. Press the ESC key to return to the initial screen, select Integrated Peripherals then VIA OnChip PCI Device.
4. Make sure Onboard Lan Boot ROM is set to [Enabled].
5. Press the F10 key then Y and Return to save the settings.
Pulling a PXE Image From a Client

You can pull (copy) a PXE image from any client managed by HP Device Manager and store it as a .img file in the Repository so that it can be pushed (written) to other clients. This is achieved using the _PXE Imaging_ template.

To pull a PXE image from a device:

1. Make sure the BIOS settings of the client device from which you want to pull an image are as described in the section “Client BIOS Settings for PXE” on page 146.

2. In the Management Console, display the OS tab containing the name of the client in its Device Tree.

3. Select the Imaging tab in the Task Templates pane then double-click on the _PXE Imaging_ template.

4. In the Template Editor - Imaging dialog, select the FTP Repository where the image will be stored.

5. Set the Action to Pull PXE image from device.
Advanced Tasks

6 Enter a name for the **PXE Image** so that you can easily identify it once it is stored in the FTP Repository.

7 If you need to overwrite any files that already exist in the FTP Repository, select **Overwrite old files on FTP Repository**.

8 Click the **Save as...** button, enter a name for this template, then click **OK**.

The template will be created and listed in the **Task Templates** pane ready for you to apply to devices.

9 Select the template then drag and drop it on the name of the client in the **Device Tree** from which you want to pull an image. The **Task Editor** will be displayed.
10 Click **OK** to apply the task to the device.

When the HP Management Agent on the client receives the task, the client will display a warning message indicating that the device will reboot in 15 seconds.

The client will shutdown then start-up in DOS mode and run the utility which copies the contents of the flash storage to an `.img` file in the FTP Repository. Note that this may take several minutes.

The progress of the image creation task will be indicated in the **Tasks** pane of the Console.

<table>
<thead>
<tr>
<th>Tasks</th>
<th>Task Name</th>
<th>Status</th>
<th>Error Code</th>
<th>Start Time</th>
<th>End Time</th>
<th>Progress</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>FWVANCE 8.1</td>
<td>Processing...</td>
<td>0</td>
<td>2007-06-03 10:45:18</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>NEO-099A6F0</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>38%</td>
</tr>
</tbody>
</table>

When the task has been completed successfully, the client will reboot as normal and the **Tasks** pane will indicate the task has finished.

<table>
<thead>
<tr>
<th>Tasks</th>
<th>Task Name</th>
<th>Status</th>
<th>Error Code</th>
<th>Start Time</th>
<th>End Time</th>
<th>Progress</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>FWVANCE 8.1</td>
<td>Finished</td>
<td>0</td>
<td>2007-06-03 10:45:18</td>
<td>2007-06-03 10:45:51</td>
<td>99%</td>
</tr>
</tbody>
</table>

An image file has now been created in the FTP Repository you specified in step 4.
Pushing a PXE Image to a Client

You can push (write) a PXE image stored in an FTP Repository to any client managed by HP Device Manager, as long as it contains enough Flash storage. This is achieved using the _PXE Imaging_ template.

To push a PXE image to a device:

1. Make sure the BIOS settings of the client device to which you want to push an image are as described in the section “Client BIOS Settings for PXE” on page 146.

2. In the Management Console, display the OS tab containing the name of the client in its **Device Tree**.

3. Select the **Imaging** tab in the **Task Templates** pane, then double-click on the _PXE Imaging_ template to display the **Template Editor**.

4. Select the FTP Repository where the PXE image file resides in the **FTP Repository** list box.

5. Select **Push PXE image to device** as the **Action** to perform.
6 Enter the name of the PXE image to push to the client in the **PXE Image Name** field.

*Note:* The **PXE Image Name** field will only list the names of PXE images if the image files have been transferred from the FTP Repository to the Server Repository using the **Repository Management** tool. However, you can manually enter the name of the image file in this field if it is not in the Server Repository, as long as it is present in the **FTP Repository** you have selected in the template.

7 Click **Save as...** to save the template with a new name.

The template will be created and listed in the **Task Templates** pane ready for you to apply to devices.

8 Drag and drop the template on the device(s) to which you want to apply the image. The **Task Editor** will be displayed.
Advanced Tasks

9 Click **OK** to apply the task to the device.

When the HP Management Agent on the client receives the task, the client will display a warning message indicating that the device will reboot in 15 seconds.

The client will shutdown then start-up in DOS mode and run the utility which copies the image file from the FTP Repository to its flash storage. Note that this may take some time.

The progress of the task will be indicated in the **Tasks** pane of the Console.

When the task has been completed successfully, the client will reboot with the new image and the **Tasks** pane will indicate the task has finished.

---

### Preparing an XPe Client for Image Distribution

The **ChangeSID** utility allows you to modify the computer SID (Security ID) in the Microsoft NT/2000/XP operating system.

*Note: Only the local administrator is authorized to run this utility.*

SID information is kept in a registry file which is used for computer and user identification in a workgroup or domain environment. The **ChangeSID** utility creates a new random SID and replaces the old one.

To use the **ChangeSID** utility, log on as a local administrator and run **ChangeSID.exe** from a command line:

**ChangeSID.exe <options>**

where `<options>` can include the following:

- **-m** Change the computer’s name to **NEO-** plus the last 6 digits of its MAC address.

- **-n <new computername>**
  Assign a new computer name. Note that if **-m** is specified, this option will be ignored.

- **-sid** Change the computer SID.

- **-all** Produces the same result as if you specified”**-m -sid”**.
Cloning an XPe Image

The **Clone XPe Image** template enables you to clone the image of an XPe device and either store the image for backup or apply it to other XPe devices of the same model type and identical flash storage size. This template does not use a PXE Server.

To clone an XPe image:

1. Select the **Imaging** tab in the **Task Templates** pane then double-click on the **Clone XPe Image** template.
2. In the **Template Editor - Imaging** dialog, select the **FTP Repository** where the cloned image will be stored.
3. In the **Image Name** field, enter a name for the cloned image that will be stored in the FTP Repository.
4. If you need to overwrite any files that already exist in the FTP Repository, select **Overwrite old files on FTP Repository**.
5. In the **Save result as template** field, enter a name for the resulting template which will be automatically created to enable you to apply the cloned XPe image to other XPe clients.
6 Click the **Save as...** button, enter a name for this template, then click **OK**.

![](image1.png)

A new template will appear in the **Task Templates** pane.

7 Drag and drop this template on the XPe device whose image you want to clone in the **Device Tree**. The **Task Editor** dialog will be displayed.

![](image2.png)
8 Click **OK** to apply the task to the device immediately.

When the HP Management Agent on the client receives the task, the client will display a warning message indicating that the device will reboot in 15 seconds.

The client will shutdown then start-up in DOS mode and run the clone utility which copies the contents of the flash storage to an `.img` file on the FTP Repository. The last line on the client display will indicate progress in percentage completed. Note that this may take several minutes.

The client will reboot after cloning has completed and enter Maintenance Mode. DO NOT turn off the device during this procedure! The client will then reboot again.

The **Tasks** pane in the Management Console will continue to indicate that the task is processing. The cloned image is being compressed.

When the task has finished, a new template will appear in the **Task Templates** pane with the name you specified in step 5 (the result template).

You can now use this template to apply the cloned XPe image to other XPe devices of the same model type and identical flash storage size just by dragging and dropping it on the device(s) in the **Device Tree**.

You can view information about the XPe image associated with the template by double-clicking on the name of the template to display the **Template Editor** dialog. This will display the name of the image and the FTP Repository where it is stored, its OS build number, original size, compressed size, and checksum.
The cloned XPe image file will also be listed in Repository Management ready for use in other templates. Select NeoXPe Images as the element type, then select the FTP Repository where it is stored.
Updating Images

The **_Update Image_** template on each OS tab enables you to apply images to devices without using a PXE Server.

To update the image on one or more devices:

1. In the Management Console, display the OS tab containing the name of the client(s) to be updated with the new image in the Device Tree.

2. Select the Imaging tab in the Task Templates pane, then double click on the **_Update Image_** template to display the Template Editor.

3. Select the FTP Repository where the image is stored.

4. Enter the name of the image file in the Image Name field.

*Note: The Image Name field will only list the names of images if the image files have been transferred from the FTP Repository to the Server Repository using the Repository Management tool.*
Advanced Tasks

However, you can manually enter the name of the image file in this field if it is not in the Server Repository, as long as it is present in the FTP Repository you have selected in the template.

The Image Information box below will provide details of the OS build version and image size for the image whose name is currently displayed in the Image Name field.

5 Click the Save as... button to save the template with a new name.

6 Drag and drop the template on to the device(s) whose image is to be updated. The Task Editor dialog will be displayed.

7 Click OK to apply the image update task to the device(s).
Changing Registry Settings

HP Device Manager can add, delete and change registry keys and their values on thin client devices using **File and Registry** templates. Additionally, the existing settings can be cloned from a device using the **Get Registry** template and then modified.

**Getting Registry Settings**

HP Device Manager can clone the system registry of a thin client device. The procedure is as follows:

1. In the Console’s **Management View**, select the OS tab corresponding to the operating system of the device from which you want to get registry settings (e.g. **NeoLinux 4**).

2. Select the **File and Registry** tab in the **Task Templates** pane, then double-click on the **Get Registry** template to display the **Template Editor**.
Advanced Tasks

3 Click the **Add** button and enter the name of the registry node from which you want to retrieve settings (e.g. desktop for desktop settings), then click **OK**.

The name of the new node will appear on the **Registry** tab of the **Template Editor**.

4 In the **Save result as template** field, enter a name for the template which will be created to store the result.

5 Click **Save as...** and enter a name which indicates the purpose of this template (get desktop settings).
6 Click **OK** and the new template will appear in the **Task Templates** pane.

7 Drag and drop this template on the device in the **Device Tree** from which you want to get registry settings. The **Task Editor** dialog will be displayed.
Advanced Tasks

8 Click **OK** to apply the task to the device immediately.

The registry settings will be retrieved from the device and stored in a new template in the **Task Templates** pane. Its name will be the one which you specified in step 4.

9 To view the retrieved registry settings, double-click on the result template to display the **Template Editor**, double-click on the **Registry** entry in the **Sub-Task** box to display the **Configure Registry Sub-Task** dialog, then click on the registry node in the **Registry Tree** panel to display the settings.
Editing Registry Settings

1. Select the File and Registry tab in the Template Pane.

2. If you are editing a previously generated Get Registry task result template, double-click the name of that template, then double-click Registry in the Sub-Task box.

If you need to create a new template, double-click the File and Registry template to display the Template Editor, then click the Add button.

Select Registry in the Sub-Task Chooser, then click OK.
The **Configure Registry Sub-Task** dialog will be displayed enabling you to edit registry settings.

You can edit the contents of the **Registry Tree** using the four buttons at the bottom of the box.

- **Add Key** enables you to add a new key under the currently selected item.
- **Add Value** enables you to add a value to the selected key.
- **Rename** enables you to rename the selected item.
- **Delete** enables you to remove the selected item.

The **Registry Settings** box will display the current settings of the key selected in the **Registry Tree**. It is divided into the following columns:
**Advanced Tasks**

**Action** Indicates the action to be applied to the registry table: add or delete a key. Click in the field to change the current setting.

**Type** Indicates the type of registry key value.

**Value Name** Displays the name of the registry key. Double-click in this field to edit it.

![Enter New Name for Registry Value]

**Value Data** Displays the data for the registry key value. Double-click in this field to edit it.

![Edit Bool]

The **Action to Perform** options determine whether the key is added or deleted. If **Add Key** is selected, the selected key will be added to the registry even if the key is empty. If **Delete Key and Value** is selected, the selected key and all values under it will be deleted. Note that there must not be any values under the specified key.

4 When you have finished modifying the template, click the **Save as...** button and enter a name for the new template.

5 Click **OK**. The new template will be created and its name will appear in the **Template Pane**.

6 You can now apply the new registry settings to one or more devices by dragging the template from the **Template Pane** and dropping it on to the device(s) in the **Device Tree**.

---

*Changing Registry Settings* 165
Installing an XPe Software Component

Software components for XPe devices must be transferred to an FTP Repository using **Repository Management** before they can be distributed to client devices.

**Transferring an XPe Software Component to the FTP Repository**

1. Download and unzip the XPe software components to a local drive.

2. Select **Tools > Repository Management** from the Console’s menu bar.

3. In the **Select an element type to display** field, select the **Software Component** option from the drop-down list box.

4. Click the **Add from local file...** button.
5 Enter the path of the software component you wish to add.

6 Select a Relay FTP Repository in order to transfer the files to the Server Repository.

The relay FTP Repository will receive the files from the Console, and temporarily hold them until they are automatically transferred to the Server Repository.

7 Click Next to start copying the files to the relay FTP Repository.

A message box will be displayed once the files have been successfully uploaded to the relay FTP Repository.

8 Click OK to automatically transfer the files from the relay FTP Repository to the Server Repository.
The **Repository Management** dialog should now display the name of the software component in the **Elements on Server Repository** field.

9. Select the **FTP Repository** where you want the new software component to be stored.

10. Select the software component then click **Upload** to upload it to the FTP Repository.

   *Note: The username selected for the FTP server profile must have write permission for the target folder.*

11. Your software component is now ready to be installed using a **Software Component** template.
Installing an XPe Software Component on Client Devices

Software components can be installed on client devices once they have been uploaded to the FTP Repository.

Note: The procedure for installing software components discussed in this section is only applicable to Windows XPe clients.

To install a software component:

1. Select the **Software Update** tab from the **Template Pane**.
2. Double click **_Software Component** template to display the **Template Editor** dialog.

![Template Editor - Software Update](image)

3. Select the **FTP Repository** containing the software component to install.

4. Select or enter the name of the **Software Component** to install from the FTP Repository.

5. Click **Save as...** to save the template with a new name.

6. Drag and drop the template on the device(s) to which you want to install the software component.
Performing a Persistent Write Operation on NeoLinux 4.x Devices

NeoLinux 4.x devices use three related file systems which are mounted as follows:

/  
/writable  
/.fs/org

Normally a user will perform all work under / or /writable, which are mounted as readable and writable when the system starts up. The file system of /writable is used for storing persistent data, where files can be created, modified or removed, and the changes will not be lost when the device reboots or shuts down.

However, the file system of / works in a different way. Any modifications made in this file system are temporary and will not be transferred to the actual disk, even though it is writable. When the device reboots or shuts down the changes will be lost and the file system of / will revert to its original state.

Sometimes you may need to perform a persistent write to / in order to run commands, utilities, scripts, etc. which require changes to be saved. This can be achieved using the third file system /.fs/org, which is mounted from the same source as /. It is possible to create, modify or remove files persistently in /.fs/org, but as it is mounted as read only you need to remount it to be writable before making any changes to the file system, then reboot the device for the changes to take effect.

The Command sub-task in the File and Registry template for NeoLinux 4 devices includes options enabling you to change the root directory to /.fs/org and mount it as writable.
The following procedure describes how to change the directory of a NeoLinux 4.x device to /fs/org and mount it as writable in order to perform commands:

1. With the NeoLinux 4 tab displayed, select the File and Registry tab in the Template Pane.
2. Double-click the _File and Registry_ template to display the Template Editor.

![Template Editor Image]

3. Click the Add button and select Command.

![Sub-Task Chooser Image]

4. Click OK to display the Execute Command Sub-Task dialog.
5 Check the **chroot /fs/org** check box at the bottom of the dialog in order to change the root directory to `/fs/org`. The **Mount to writable** option will then be available. Check this box as well.

Any commands you specify in this dialog will now be directed to `/fs/org` which will be mounted as writable.

6 Specify the command(s) to execute, then click **OK** when you have finished.

7 Select the **Reboot after all subtask finished** option.

8 Click **Save As...** to save the template under a new name.

9 Drag and drop the template on the devices where you want the commands to run.
Adding Devices Using MAC Addresses

Devices that are not working and need a new image, or that otherwise have not been found by HP Device Manager, can be added to the console using their MAC address. However, devices added to the console in this manner cannot be fully managed by HP Device Manager until the agent on the device reports to the HP Management Server properly.

The primary use of this feature is if the device is not working and needs a new image. An image can be pushed to the device using a template. Another way to use this feature is to Wake On LAN a device that has not previously been reported to the HP Management Server and therefore is not displayed in the device tree.

To add a new device using its MAC address:

1. Select Device > Add from the Management Console menu bar.

The Add Device dialog will be displayed.
2 Enter the **MAC Address** of the device to be added.

3 Select the Management Gateway that will connect with the device from the **Neoware Management Gateway ID** drop-down list.

4 Click **OK** to add the device.

A new device will appear in the device tree with the name \texttt{deviceX}, where \texttt{X} is a number. This device will appear as powered-off, but you can still interact with the device. For example, you can use **Send Task** to send a new **Imaging** template to the device, or **Wake on LAN** to attempt to start up the device.
The **Agent** templates enable you to set agent parameters and update the agent version.

### Setting Agent Parameters

The **Configure Agent** template enables you to specify how often it pulls tasks from the Management Gateway, set the delay scope, and specify the type of log information that will be generated.

1. Double-click the **Configure Agent** template on the **Agent** tab of the Template Pane.

2. Select the **Pull Interval** from the list.

3. Select the **Delay Scope** from the list.

4. Select the **Log Level** from the list.

5. Click **Save as...** to save the template with a new name.

6. Drag and drop the template on the device(s) you want to configure.
Advanced Tasks

**UpdAting the Agent Version**

The _Update Agent_ template enables you to apply the latest version of the Agent file to client devices. Agent update files must be added to an FTP Repository using Repository Management before they can be applied to client devices.

1. Double-click the _Update Agent_ template on the Agent tab of the Template Pane.

   ![Template Editor - Agent](image)

2. Specify the location of the Agent update files by selecting from the FTP Repository list.

3. Click the Verify Files On FTP button to check whether the correct Agent files are located on the specified FTP Repository.

![Verification Completed](image)

4. Click Save as... to save the template with a new name.

5. Drag and drop the template on the device(s) you want to update.
CHAPTER 7  

Configuration Management

This chapter explains the administration of the console, working with users, advanced server configuration, and licensing.

User Management

Each user account can have customized permissions, according to their level of need. These are assigned through the user groups system.

Working With Users  

To add users:

1. Display the Tools menu from the Console’s menu bar and select User Management.
2 Click **Add** to add a new user. The **Create New User** dialog will be displayed.

![Create New User Dialog]

3 Enter a **Username** for the new user and specify a **Password**. Click **OK** to create the new user.

4 Refer to the instructions below in order to add the new user to a user group. Note that the user must be added to a group before it has any permissions to use HP Device Manager.

   This user name can be used to log in to the console the next time the console starts.

**To delete users:**

1 Display the **Tools** menu from the menu bar and select **User Management**.

2 Select a user in the **User Management** dialog.

3 Click **Delete** then **Yes** to confirm that you want to delete the selected user from the list.

**To assign users to groups:**

1 In the **User Management** dialog, double-click a user name in the **Users** list to edit the user.

2 Select the **Member Of** tab.
3 Click **Add** to add the user to a new group, or **Delete** to remove the user from the selected group.

**To change a user’s password:**

1 In the **User Management** dialog, right-click on the name of the user whose password needs to be changed.

2 Select **Change Password** from the pop-up menu.

3 Enter the **New Password** for the user, then re-enter it in the **Confirm Password** field.

4 Click **OK** to finish.

*Note: When you log in as root for the first time, it is strongly recommended that you change the password from the default.*
**Working With Groups**

Groups can be used to control user permissions in HP Device Manager.

**To add a group:**

1. Display the **Tools** menu from the Console’s menu bar and select **User Management**. Select the **Groups** tab.

   ![User Management Dialog](image)

   2. Click **Add** to add a new group. This group can now be assigned a set of permissions, and then users can be assigned to this group.

**To assign permissions to groups:**

1. In the **All Groups** list, right-click the group you wish to modify.

2. Select **Properties** in the pop-up menu.

3. Select the **Privileges** tab.
4 Select the permissions you wish to assign to the group.
5 Click OK to finish.

**To assign users to groups:**

1 Right-click the group you wish to modify in the Groups tab of the User Management dialog.
2 Select Properties in the pop-up menu.
3 Select the Users tab.
Configuration Management

4 Use the **Add** and **Delete** buttons to modify the members of this group.

5 Click **OK** to finish.

**To delete a group:**

1 Select the name of the group to be deleted in the **All Groups** list on the **Groups** tab.

2 Click the **Delete** button then **Yes** to confirm that you want to delete the selected group from the list.
FTP Repositories

Configuring an FTP Repository

1. Select **Tools > Configuration** from the Console’s menu bar.
2. In the **Configuration Management** dialog, select the **FTP Repositories** item in the left-hand tree pane.

3. Different server profiles can be used to access different FTP servers or different parts or accounts of the same FTP server. Click **Add** to configure a new server.

4. Enter a repository name to be used by HP Device Manager to refer to the new repository, then click **OK**.
5 Fill in the Server Address, Username, Password and Path settings. For example:

**Server Address:** 192.168.88.7 (FTP server IP address)

**Username:** john

**Password:** dev1234 (input will appear hidden)

**Path:** ./ndm

*Note: You need to have write permissions for the given path.*

The files will be stored at /home/john/ndm/ where /home/john is the default login directory of user john.

6 You can click Test if you want to try the connection to the server. If there is a problem, click Undo Changes to recover the last saved settings.

7 If you want this Repository to be your default FTP server, click Set Default.

8 Click Apply to save the settings.

---

**Deleting a Repository**

1 Select Tools > Configuration from the Console’s menu bar.

2 In the Configuration Management dialog, select the FTP Repositories item in the left-hand tree pane.

3 Select the repository you want to delete in the FTP Repositories list, click Delete then Yes to confirm.

**Exporting a Repository**

1 Select Tools > Configuration from the Console’s menu bar.

2 In the Configuration Management dialog, select the FTP Repositories item in the left-hand tree pane.

3 Select the repository you want to export in the FTP Repositories list, then click Export.

4 Browse to the location where you want to save it.

5 Click Export FTP Repositories.
Importing a Repository

1. Select **Tools > Configuration** from the Console’s menu bar.
2. In the **Configuration Management** dialog, select the **FTP Repositories** item in the left-hand tree pane.
3. Click **Import...**
4. Browse to the location where the FTP Repository you want to import is located.
5. Click **Import FTP Repositories**.

*Note: The first FTP Repository imported will become the default FTP Repository unless another has already been defined as such.*

FTP Repository Selection for Templates

Where applicable, each template allows you to define the method used to find the required FTP Repository. The **Content** tab of the **Template Editor** dialog will include an **FTP Repository** drop-down list box providing the following three possibilities:

- **Use Default**
  You preset a default server. To do this, select **FTP Repositories** in the left-hand tree pane of the **Configuration Management** dialog, select the name of the FTP Repository to use by default in the **FTP Repositories** list, then click the **Set Default** button.

- **Auto Mapping**
  The HP Management Server will find the corresponding FTP server for each device according to the mapping defined in the **FTP Mappings** definitions. (See “FTP Mappings” on page 186.)

- **Use Specific FTP**
  You choose a specific FTP server for each template.
FTP Mappings

The **FTP Mappings** tool automatically maps each and every client device to the nearest and most convenient FTP server. This allows the administrator to send tasks to a large number of agents, and have the device connect automatically to an FTP server to find the information or applications it may need to perform the task.

To configure the **FTP Mappings** tool, select **Tools > Configuration** from the Console’s menu bar, expand the **FTP Mappings** item in the left-hand tree pane of the **Configuration Management** dialog, then select either **Device FTP Mapping** or **Subnet FTP Mapping**.

### Listing Devices & their FTP Servers

You can list devices and their FTP servers by selecting the **Device FTP Mapping** item in the left-hand tree pane of the **Configuration Management** dialog. A color code indicates how each device’s FTP server was assigned:

- **Blue**
  Automatic mapping (factory default settings). The HP Management Server assigns an FTP server to each device depending on which subnet it is connected to.

- **Red**
  Uses a default FTP server, usually a server with highest broadband. The default FTP server can be changed at any time, so that the devices assigned “default FTP” would connect to the new FTP server.
Green Uses a static FTP server specified by the administrator.

Note: An administrator can change the FTP settings of a device or a subnet at any time. The administrator can also change the default FTP server and that will affect all the devices that use this option.

Note: HP Device Manager will automatically map any new device added to the network.

Listing Subnets & their FTPs Servers You can list subnets and their FTP servers by selecting the Subnet FTP Mapping item in the left-hand tree pane of the Configuration Management dialog. A color code indicates how their FTP server was assigned:

- **Blue**
  Automatic mapping (factory default settings). The HP Management Server assigns an FTP server to each subnet according to its proximity. For example, a subnet that has an FTP server will be using that server instead of another one in the entire network.
Red
Uses a default FTP server, usually a server with highest bandwidth. The default FTP server can be changed at any time, so that the subnets assigned “default FTP” would connect to the new FTP server.

Green
Uses an FTP server specified by the administrator. For subnets where this is the case, the administrator can change their FTP settings to automatic mapping or default.

Filtering Devices or Subnets
For companies with a large number of devices and/or subnets, the Device FTP Mapping and Subnet FTP Mapping listings will be too long for an administrator to easily find a particular device or to see certain aspects. You can filter these mappings so that the administrator can manage both the general and the specific aspects of each device.
On both the **Device FTP Mapping** and the **Subnet FTP Mapping** tabs, click **Filter** to display a dialog which enables you to filter the listing in various ways. Choose one of the filtering options then click **OK**.
Grouping properties can be used in grouping schemes for grouping devices.

1. Select **Tools > Configuration** from the Console’s menu bar.

2. In the **Configuration Management** dialog, select the **Grouping Property Name** item in the left-hand tree pane.

3. Enter the name of the grouping property in the relevant **Grouping Property Name** field.

4. Click **OK** when you have finished.
Task Parameters

You can set task parameters by selecting **Tools > Configuration** from the Console’s menu bar to display the **Configuration Management** dialog, then expanding the **Task Parameters** item in the left-hand tree pane.

The **Task Parameters** item consists of two sub-items: **Valid Time and Timeout** and **Write Filter Policy Setting**. These are described in the following sections.

**Valid Time and Timeout**

The **Valid Time and Timeout** options enable you to set the duration HP Device Manager will wait for the execution of tasks. You can also specify the start and end time of working hours during which HP Device Manager will not execute tasks. Clicking in an option field will cause the **Description** box to display a short description of that option.

1. Select **Valid Time and Timeout** in the left-hand tree pane of the **Configuration Management** dialog.
Set the time, in minutes, for each category: **Valid Time**, **General Timeout**, **General Batch Interval**, **PXE Batch Interval** and **FTP Batch Interval**.

Set the amount, in devices, for each category: **General Batch Amount**, **PXE Batch Amount** and **FTP Batch Amount**.

Check the **Exclude Working Hours** option box to input the start and end time of working hours.

Clicking **Restore defaults** will reset the timeout settings to their defaults and set the working hours to **9.00** start and **17.00** end.

Click **Apply** to save the new settings, then **OK** to exit.

---

### Write Filter Policy Setting

The **Write Filter Policy Setting** options enable you to specify how the Enhanced Write Filter on XPe devices affects tasks.

1. Select **Write Filter Policy Setting** in the left-hand tree pane of the **Configuration Management** dialog.

2. Choose one of the three policy options.

3. Click **Apply** to save the new settings, then **OK** to exit.
Task Settings

You can specify general task settings by selecting **Tools > Configuration** from the Console’s menu bar to display the **Configuration Management** dialog, then selecting the **Task Settings** item in the left-hand tree pane.

The **PXE Image** option enables you to show progress information for PXE image tasks.

The **VNC Access Password** fields enable you to specify a password that must be supplied to enable shadowing. Note that these fields cannot be blank.

If the **Cancel Task** option is checked, a ’cancel task’ command will be sent to the Management Gateway when deleting tasks from the Console.

If the **Try Once** option is checked, the Management Gateway will only attempt to send a task once.
The Status Walker configuration options enable you to specify the walking group size, timeout and retry times, and specify the user name and password for three telnet configurations.

Select **Tools > Configuration** from the Console’s menu bar to display the **Configuration Management** dialog, then select the **Status Walker Configuration** item in the left-hand tree pane.

Clicking in an option field will cause the **Description** box to display a short description of that option.
A license file contains information for the maximum number of clients your HP Management Server can support concurrently and the expiration date for the license. If more clients need to be supported and the number is over the maximum in the license file, HP can be contacted for another license file. Once this file has been obtained it must be imported into HP Device Manager.

The HP Management Server icon in the Windows Systray will turn red if the license expires. Consequently the HP Management Console will not connect to the Management Server until a new license file is imported.

You can view information about your current license by selecting Help > About from the Console’s menu bar.

**Importing a New License**

You can only import a new license file through the Management Console if the old license has already expired. Any invalid operation to the license file when the Management Server is running will cause the server to crash.

1. Select File > Import License... from the Console’s menu bar to display the Open dialog.

2. Browse for the new license file and select it. (The license file has the extension “.lic”.)

3. Click Choose.

The Management Server will reboot automatically before the Console continues to work under the new license.
Authentication Management

Since the HP Management Server can discover and manage all HP Device Manager gateways and agents on the network, a security problem may occur due to the improper usage of the Management Server. To overcome this, HP Device Manager provides an authentication capability for the gateways and the agents to recognize a secure Management Server.

There are two tools for providing authentication: **Key Management** and **Gateway Access Control**. These are accessed by selecting **Tools > Authentication Management** in the Console’s menu bar.

**Key Management**

An Authentication Key is a plain text password which is input on the Management Console. The key will be passed to the devices during the key update process. The devices will check the key passed by Management Server when executing tasks.

**To update the current Authentication Key:**

1. Select **Tools > Authentication Management > Key Management** in the Console’s menu bar to display the **Authentication** dialog.

2. Enter your user **Password** then click **OK**. The **Key Management** window will be displayed.
3 Click the **Update Current Key...** button to display the **Update Key** dialog.

4 Enter the new **Password** (i.e. the Authentication Key) and specify the **Expire Interval** (number of days).

5 Click the **OK** button.
Configuration Management

Note: **Expire Interval** is the time that the password (Key) keeps valid. If an agent cannot contact a gateway for key information before a specified time (Expiration Interval), the Key will expire, (i.e., no longer in use) and the agent will revert to its initial key.

HP recommends that user passwords contain:

- at least eight characters
- letters of both upper and lower cases
- numbers and punctuations as well as letters

**To export all Authentication Key(s):**

1. Click the **Export All Key(s)** button in the **Key Management** window to display the **Export** dialog.

![Export Dialog]

2. Browse for a folder to save the current authentication key(s) as a *.ks* file, then click the **Export** button.

3. The system will prompt you to create and confirm the KeyStore password.

---

198 Authentication Management
4 In the **Create KeyStore Password** dialog, enter a KeyStore **Password** and confirm the password in the **Re-enter Password** field.

5 Click the **OK** button.

**To import Authentication Key(s):**

1 Click the **Import Key(s)** button in the **Key Management** window to display the **Import** dialog.

2 Browse for the exported *.ks file, then click the **Import** button.

3 The system will prompt you to enter the KeyStore password.
4 Enter the KeyStore **Password** then click the **OK** button.

**Viewing the Key Update Log**

To view the **Key Update Log**, click the **View Update Log...** button in the **Key Management** window.

In the **Key Update Log List** you can view all the log times and events. You can remove all the logs by clicking the **Clear All Logs** button.
Gateway Access Control

The Management Server will maintain the acknowledge status of a gateway which is specified by the user from the Management Console. When a gateway is discovered by the Management Server, the gateway is set as Unknown status. The Management Server will not establish any connection with a gateway nor receive any messages sent by the banned gateway unless the gateway is acknowledged.

To control Gateway access manually:

1. Select **Tools > Authentication Management > Neoware Management Gateway Access Control...** from the Console’s menu bar to display the **Authentication** dialog.

2. Enter your password then click **OK**. The **Neoware Management Gateway Access Control** window will be displayed.

3. Select a gateway from the **Gateway Access Control List**, then click the **Acknowledge** or **Ban** button to recognize or ban the selected gateway.
Configuration Management

Note: If the Manually control Gateway access option is unchecked, the gateway with the Unknown status is regarded as Acknowledged. When this option is selected, the gateway with the Unknown status is regarded as Banned and you need to configure the status of the gateway manually.

Report Management

Adding a Report Template

To add a report template:

1. Select Tools > Report Management from the Console’s menu bar to display the Report Management window.

2. Select one report type from the Report Types list, then click the Add button. A Set New Report Template Name dialog will prompt you to input a report template name.
3 Click **OK** to open the **Edit Report Template** window. In the **Edit Criteria** field, click the ... button to open the **Choose Criteria Key** window. Select a criteria key in the **Candidate Criteria Key List**.

After you have made the selection, click **OK** to return to the **Edit Report Template** window.
4 In the **Edit Criteria** field, select or enter the criteria conditions in the two drop-down lists.

Click **Add** to add the criteria into the **Criteria List** below, or you can select an existing criteria then click **Update** to renew the restricted condition.
Note: The Report Template can contain several criteria and each criteria could have one of two kinds of relationships: Satisfy All Criteria or Satisfy Any Criteria. So you can select either of them to generate reports.

5. Click Generate Reports to generate the report according to the current criteria, or click Save to add these criteria to the named template.

Note: The modified criteria will not be saved in the template after generating a report. You need to click the Save button to save the modified criteria in the template.
Importing a Report Plug-in File

To import a report plug-in file:

1. Click **Import** in the **Report Management** window, then select a plug-in file (*.jar).

2. Click **Import Plug-in File** to import the file and return to the **Report Management** window. A new report type is added to the **Report Types** list.

You can remove a report type from the list by selecting it then clicking the **Delete** button. You will be prompted to confirm that you want to delete it.
**Note:** The imported report types can be deleted only if there is no template belonging to the reported type.

**Generating a Report Using a Report Template**

To generate a report using a report template:

1. In the **Report Management** window, select a report type from the **Report Types** list and all the report templates belong to the selected type will be displayed in the **Report Templates** list.

2. Select a template from the list then click **Edit**, or double click on the template to view the template's content.
3. Click **Generate Report** to preview the report.
To add a device version alias:

1. Select **Tools > Alias Management** from the Console’s menu bar to display the **Alias Management** window.

2. If necessary, click on the **Device Version Alias** tab to open the corresponding panel.

3. Click the **Add...** button to display the **Add Device Version Alias** dialog, in which you can add a new record.

4. Enter the device version and alias, then click **OK**. The new record will be added to the **Device Version Alias** panel.
To edit an existing device version alias, you need to select a record in the **Device Version Alias** panel then click the **Edit** button.

In the **Edit Device Version Alias** dialog, change the alias then click **OK** to save your modifications.

If you want to remove a record from the **Device Version Alias** panel, just select a record and click the **Delete** button.
To add a subnet address alias:

1. Select **Tools > Alias Management** from the Console’s menu bar to display the **Alias Management** window.

2. Click on the **Subnet Address Alias** tab.

3. Click the **Add...** button to display the **Add Net Address Alias** dialog, in which you can add a new record.

4. Input the subnet address and alias, then click **OK**. The new record will be added to the **Subnet Address Alias** panel.

To edit an existing subnet address alias, select a record in the **Subnet Address Alias** panel then click the **Edit** button. In the **Edit Subnet Address Alias** dialog you can change the alias then click **OK** to save your modifications.

If you want to remove a record from the **Subnet Address Alias** panel, just select a record and click the **Delete** button.
Exporting an Alias  To export an alias:

1. In the **Alias Management** window, select a record and click the **Export** button to open the **Export Alias** dialog.

2. Browse for a folder to save the current alias as an *.xml* file, then click the **Export Alias** button.

Importing an Alias  To import an alias:

1. Click the **Import** button in the **Alias Management** window to display the **Import Alias** dialog.
2 Browse for the exported *.xml file then click the **Import Alias** button. The imported alias will be added to the current list.

## Template Plugin Management

### Importing a Template Plugin

To import a Template Plug-in:

1. Select **Template > Template Plugin Management** from the Console’s menu bar to display the **Template Plugin Management** window.

2. Click the **Import** button to display the **Select Import Files** dialog.

3. Browse for the exported *.jar file, select it then click the **OK** button.

4. The imported plugin will be displayed as a new tab with a new template in the **Template Pane**.
Removing a Template Plugin

To remove a Template Plugin:

1. In the Template Plugin Management window, select a record and click the Uninstall button.

2. You will be prompted to confirm that you want to uninstall the selected template. Click Yes to uninstall.

3. The template tab associated with the uninstalled template plugin will be deleted from the Template Pane.
APPENDIX A

Installing & Running JRE

This appendix describes how to install and run the Java Runtime Environment.

Introduction

A Java Runtime Environment of version 1.41 or later, including any Java2 platform system, is required to run HP Device Manager. You can install the correct Java Runtime Environment from the HP Device Manager installation CD.

Windows-based Server Installation

To install the Java Runtime Environment for Windows based servers:

1. Navigate to the directory \[CD]\:\jre (where \[cd]\: is the drive letter of your installation CD.)

2. Double-click \j2re-1_4_1_02-windows-i586-i.exe.

3. Install the Java Runtime Environment following the on-screen instructions.

The Java Runtime Environment is now ready for HP Device Manager to be installed.
Linux-based Server Installation

To install the Java Runtime Environment for Linux based servers:

1. Login as root.
2. Enter the following commands:
   ```shell
   cd /usr/local
   cp /[CD]/j2re-1_4_1_02-linux-i586.bin /usr/local
   (where [CD] is the path to the HP Device Manager CD).
   sh j2re-1_4_1_02-linux-i586.bin
   ln -s j2sdk1.4.1_02 j2sdk
   ```
3. Set an environment variable JAVA_HOME to the pathname of the directory into which you install the JDK:
   ```shell
   vi /etc/profile
   ```
   Add the following lines just before "export PATH..."
   ```shell
   PATH=/usr/local/j2sdk/bin:$PATH
   JAVA_HOME=/usr/local/j2sdk
   export PATH ... JAVA_HOME
   ```
This appendix describes how to install and run MySQL.

Installing MySQL on Linux-based Servers

1. Login as root.
2. Enter the following commands:
   
   ```shell
   shell> groupadd mysql
   shell> useradd -g mysql mysql
   shell> cd /usr/local
   shell> gunzip < /path/to/mysql-VERSION-OS.tar.gz | tar xvf -
   shell> ln -s full-path-to-mysql-VERSION-OS mysql
   shell> cd mysql
   shell> scripts/mysql_install_db
   shell> chown -R root
   shell> chown -R mysql data
   shell> chgrp -R mysql
   ```
Running MySQL on Linux-based Servers

To run MySQL on Linux-based servers type the following:

```
shell> bin/safe_mysqld --user=mysql &
```

If you want to start MySQL automatically:

1. Copy `/support-files/mysql.server` to the directory which contains the startup files.
2. Enter the following commands:
   ```
   shell> chmod a+x mysql.server
   shell> cp mysql.server /etc/rc.d/init.d/mysql
   shell> ln -s /etc/rc.d/init.d/mysql /etc/rc.d/rc3.d/S99mysql
   shell> ln -s /etc/rc.d/init.d/mysql /etc/rc.d/rc0.d/S01mysql
   shell> chkconfig --add mysql
   ```
3. Reboot the server.
**APPENDIX C**

**Error Code Reference**

*This appendix explains the meaning of error codes which may be generated by HP Device Manager.*

### Error Codes

The following table lists the error codes which may be generated by HP Device Manager and explains their meaning.

<table>
<thead>
<tr>
<th>Error Code</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>0</td>
<td>Success.</td>
</tr>
<tr>
<td>1</td>
<td>Could not connect with target Management Agent.</td>
</tr>
<tr>
<td>2</td>
<td>The system cannot find the file specified.</td>
</tr>
<tr>
<td>3</td>
<td>The system cannot find the path specified.</td>
</tr>
<tr>
<td>4</td>
<td>The system cannot open the file.</td>
</tr>
<tr>
<td>5</td>
<td>Access is denied.</td>
</tr>
<tr>
<td>7</td>
<td>Report is received, but the report is corrupt or malformed.</td>
</tr>
<tr>
<td>8</td>
<td>Task is not found in the Management Gateway.</td>
</tr>
<tr>
<td>9</td>
<td>Management Agent information is lost in Management Gateway. Management Server is synchronizing Management Agent information with Management Gateway. Please resend the task another time.</td>
</tr>
<tr>
<td>10</td>
<td>Management Gateway failed to send task to Agent.</td>
</tr>
<tr>
<td>Error Code</td>
<td>Description</td>
</tr>
<tr>
<td>------------</td>
<td>--------------------------------------</td>
</tr>
<tr>
<td>201</td>
<td>Image size larger than flash size.</td>
</tr>
<tr>
<td>202</td>
<td>Cannot connect to FTP Server.</td>
</tr>
<tr>
<td>203</td>
<td>Login error.</td>
</tr>
<tr>
<td>204</td>
<td>Image file does not exist.</td>
</tr>
<tr>
<td>205</td>
<td>Image file transfer failed.</td>
</tr>
<tr>
<td>206</td>
<td>MD5 file does not exist.</td>
</tr>
<tr>
<td>207</td>
<td>MD5 file transfer failed.</td>
</tr>
<tr>
<td>208</td>
<td>MD5 verification error.</td>
</tr>
<tr>
<td>209</td>
<td>Read flash error.</td>
</tr>
<tr>
<td>210</td>
<td>Write flash error.</td>
</tr>
<tr>
<td>211</td>
<td>Offset too large.</td>
</tr>
<tr>
<td>212</td>
<td>Get MAC address error.</td>
</tr>
<tr>
<td>213</td>
<td>Unknown command error.</td>
</tr>
<tr>
<td>214</td>
<td>MD5 file creation error.</td>
</tr>
<tr>
<td>215</td>
<td>FTP path error.</td>
</tr>
<tr>
<td>216</td>
<td>Cannot use BINARY mode in FTP transfer.</td>
</tr>
<tr>
<td>217</td>
<td>File already exists.</td>
</tr>
<tr>
<td>218</td>
<td>File and flash of different OS type.</td>
</tr>
<tr>
<td>220</td>
<td>Cannot connect to FTP Server.</td>
</tr>
<tr>
<td>221</td>
<td>Login FTP error.</td>
</tr>
<tr>
<td>222</td>
<td>Unknown command error.</td>
</tr>
<tr>
<td>223</td>
<td>Error with both PASV and PORT modes in FTP transfer.</td>
</tr>
<tr>
<td>300</td>
<td>Unknown error.</td>
</tr>
<tr>
<td>301</td>
<td>Failure connecting to PXE Server.</td>
</tr>
<tr>
<td>Error Code</td>
<td>Description</td>
</tr>
<tr>
<td>------------</td>
<td>-------------</td>
</tr>
<tr>
<td>302</td>
<td>Failure getting PXE task.</td>
</tr>
<tr>
<td>303</td>
<td>Invalid task format.</td>
</tr>
<tr>
<td>304</td>
<td>Failure pulling image (image file already exists).</td>
</tr>
<tr>
<td>305</td>
<td>Failure uploading file to FTP Server.</td>
</tr>
<tr>
<td>306</td>
<td>Failure executing PXE task (flash unsupported).</td>
</tr>
<tr>
<td>307</td>
<td>Failure uploading MD5 file.</td>
</tr>
<tr>
<td>308</td>
<td>Failure finding PXE server.</td>
</tr>
<tr>
<td>309</td>
<td>Failure pushing image file (file does not exist).</td>
</tr>
<tr>
<td>310</td>
<td>Failure pushing image MD5 file (file does not exist).</td>
</tr>
<tr>
<td>311</td>
<td>Failure downloading image file from FTP server.</td>
</tr>
<tr>
<td>312</td>
<td>Failure downloading MD5 file from FTP server.</td>
</tr>
<tr>
<td>313</td>
<td>Invalid image file size.</td>
</tr>
<tr>
<td>14000022</td>
<td>Unknown Error.</td>
</tr>
<tr>
<td>14000032</td>
<td>Time out.</td>
</tr>
<tr>
<td>14000042</td>
<td>Service terminated.</td>
</tr>
<tr>
<td>14000052</td>
<td>Unsupported task.</td>
</tr>
<tr>
<td>14000062</td>
<td>Allocate memory blocks error.</td>
</tr>
<tr>
<td>14000072</td>
<td>Child process crashed.</td>
</tr>
<tr>
<td>14001012</td>
<td>Registry path is empty.</td>
</tr>
<tr>
<td>14001022</td>
<td>Registry path is invalid.</td>
</tr>
<tr>
<td>14001032</td>
<td>Open HKEY_CURRENT_USER failure.</td>
</tr>
<tr>
<td>14001042</td>
<td>Registry task is empty.</td>
</tr>
<tr>
<td>14001052</td>
<td>Unknown registry type.</td>
</tr>
<tr>
<td>14001062</td>
<td>Open key failure.</td>
</tr>
</tbody>
</table>
### Error Code Reference

<table>
<thead>
<tr>
<th>Error Code</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>14001072</td>
<td>Enumerate value failure.</td>
</tr>
<tr>
<td>14001082</td>
<td>Delete registry item failure.</td>
</tr>
<tr>
<td>14001082</td>
<td>Delete registry value failure.</td>
</tr>
<tr>
<td>14002012</td>
<td>Invalid XML format.</td>
</tr>
<tr>
<td>14002022</td>
<td>Invalid version.</td>
</tr>
<tr>
<td>14002032</td>
<td>Unknown Clone or not.</td>
</tr>
<tr>
<td>14002042</td>
<td>Unknown task ID.</td>
</tr>
<tr>
<td>14002052</td>
<td>Unknown item parameter.</td>
</tr>
<tr>
<td>14002062</td>
<td>Unknown FTP parameter.</td>
</tr>
<tr>
<td>14002072</td>
<td>Unknown task content.</td>
</tr>
<tr>
<td>14002082</td>
<td>Attachment error.</td>
</tr>
<tr>
<td>14003012</td>
<td>Set display parameter failure.</td>
</tr>
<tr>
<td>14003022</td>
<td>Set DNS failure.</td>
</tr>
<tr>
<td>14003032</td>
<td>Set Gateway failure.</td>
</tr>
<tr>
<td>14003042</td>
<td>Set host name failure.</td>
</tr>
<tr>
<td>14003052</td>
<td>Set IP mask failure.</td>
</tr>
<tr>
<td>14003062</td>
<td>Set IP failure.</td>
</tr>
<tr>
<td>14003072</td>
<td>Set DHCP failure.</td>
</tr>
<tr>
<td>14003082</td>
<td>Get display parameter failure.</td>
</tr>
<tr>
<td>14003092</td>
<td>Get DNS failure.</td>
</tr>
<tr>
<td>14003102</td>
<td>Get IP failure.</td>
</tr>
<tr>
<td>14003112</td>
<td>Get IP mask failure.</td>
</tr>
<tr>
<td>14003122</td>
<td>Get host name failure.</td>
</tr>
<tr>
<td>14003132</td>
<td>Get Gateway failure.</td>
</tr>
<tr>
<td>Error Code</td>
<td>Description</td>
</tr>
<tr>
<td>-------------</td>
<td>--------------------------------------------------</td>
</tr>
<tr>
<td>14003142</td>
<td>Get IP failure.</td>
</tr>
<tr>
<td>14003152</td>
<td>Not logged in.</td>
</tr>
<tr>
<td>14004012</td>
<td>Unknown registry parameter.</td>
</tr>
<tr>
<td>14004022</td>
<td>Command line error.</td>
</tr>
<tr>
<td>14004032</td>
<td>Unknown software component parameter.</td>
</tr>
<tr>
<td>14004042</td>
<td>Unknown VNC parameter.</td>
</tr>
<tr>
<td>14004052</td>
<td>Unknown pause parameter.</td>
</tr>
<tr>
<td>14004062</td>
<td>Cancelled by user.</td>
</tr>
<tr>
<td>14004072</td>
<td>Registry value is too long.</td>
</tr>
<tr>
<td>14004082</td>
<td>Get registry value failure.</td>
</tr>
<tr>
<td>14004092</td>
<td>Registry results overflowed.</td>
</tr>
<tr>
<td>14004102</td>
<td>No VNC password.</td>
</tr>
<tr>
<td>14004112</td>
<td>Set VNC password failure.</td>
</tr>
<tr>
<td>14004122</td>
<td>No element found.</td>
</tr>
<tr>
<td>14004132</td>
<td>Create VNC process failure.</td>
</tr>
<tr>
<td>14005002</td>
<td>Verify MD5 failure.</td>
</tr>
<tr>
<td>14006012</td>
<td>Connect FTP failure.</td>
</tr>
<tr>
<td>14006022</td>
<td>FTP error.</td>
</tr>
<tr>
<td>14006032</td>
<td>Could not find specified file or dir in FTP.</td>
</tr>
<tr>
<td>14006042</td>
<td>Invalid file.</td>
</tr>
<tr>
<td>14006052</td>
<td>No update file found.</td>
</tr>
<tr>
<td>14007012</td>
<td>Invalid Write Filter.</td>
</tr>
<tr>
<td>14007022</td>
<td>No Write Filter driver found.</td>
</tr>
<tr>
<td>14007032</td>
<td>Write Filter error.</td>
</tr>
<tr>
<td>Error Code</td>
<td>Description</td>
</tr>
<tr>
<td>------------</td>
<td>-------------</td>
</tr>
<tr>
<td>14007042</td>
<td>Write Filter enabled.</td>
</tr>
<tr>
<td>14008012</td>
<td>Retry update key.</td>
</tr>
<tr>
<td>14008022</td>
<td>Get new key failure.</td>
</tr>
<tr>
<td>14008032</td>
<td>Get current key failure.</td>
</tr>
<tr>
<td>14008042</td>
<td>Decrypt new key failure.</td>
</tr>
<tr>
<td>14008052</td>
<td>Update new key failure.</td>
</tr>
<tr>
<td>14009012</td>
<td>Get Write Filter persistent data failure.</td>
</tr>
<tr>
<td>14009022</td>
<td>Set Write Filter persistent data failure.</td>
</tr>
<tr>
<td>14010012</td>
<td>Delete dir or file failure.</td>
</tr>
<tr>
<td>14010022</td>
<td>Open file failure.</td>
</tr>
<tr>
<td>14010032</td>
<td>Read file failure.</td>
</tr>
<tr>
<td>14010042</td>
<td>Write file failure.</td>
</tr>
<tr>
<td>14010052</td>
<td>File content error.</td>
</tr>
<tr>
<td>14011012</td>
<td>No Linux config file group found.</td>
</tr>
<tr>
<td>14011022</td>
<td>No Linux config file item found.</td>
</tr>
<tr>
<td>14012012</td>
<td>Linux platform response error.</td>
</tr>
<tr>
<td>14013012</td>
<td>Platform interface enumerate task error.</td>
</tr>
<tr>
<td>14013022</td>
<td>Platform Interface BeginTask() exception.</td>
</tr>
<tr>
<td>14013030</td>
<td>Platform interface reboot.</td>
</tr>
<tr>
<td>14013042</td>
<td>Platform interface BeginTask() error.</td>
</tr>
<tr>
<td>14014012</td>
<td>Invalid or unmatched type of web browser.</td>
</tr>
<tr>
<td>14020022</td>
<td>Open description file error.</td>
</tr>
<tr>
<td>14020032</td>
<td>Cloning failed because of missing parameters from Linux side.</td>
</tr>
<tr>
<td>14020042</td>
<td>Description file’s format is not correct.</td>
</tr>
<tr>
<td>Error Code</td>
<td>Description</td>
</tr>
<tr>
<td>-------------</td>
<td>-----------------------------------------------------------------------------</td>
</tr>
<tr>
<td>14020052</td>
<td>Create description file error.</td>
</tr>
<tr>
<td>14020062</td>
<td>Image info from task is different to info from description file on FTP Server.</td>
</tr>
<tr>
<td>14020072</td>
<td>Image file already exists on FTP Server.</td>
</tr>
<tr>
<td>14020082</td>
<td>Prepare info for update.ini error.</td>
</tr>
<tr>
<td>14020092</td>
<td>Write info to update.ini error.</td>
</tr>
<tr>
<td>14020102</td>
<td>Execute SwitchOS.cmd error.</td>
</tr>
<tr>
<td>14020112</td>
<td>Not enough space available.</td>
</tr>
<tr>
<td>14020122</td>
<td>Copy menu.1st file from 'C:\Windows\system32\Grub' to 'd:\Windows\System32\Grub' error.</td>
</tr>
<tr>
<td>14020132</td>
<td>Copy menu_update.1st file from 'C:\Windows\system32\Grub' to 'd:\Windows\System32\Grub' error.</td>
</tr>
<tr>
<td>14020142</td>
<td>Copy stage2 file from 'C:\Windows\system32\Grub' to 'd:\Windows\System32\Grub' error.</td>
</tr>
<tr>
<td>14020152</td>
<td>Create directory: 'd:\Windows' error.</td>
</tr>
<tr>
<td>14020162</td>
<td>Create directory: 'd:\Windows\system32' error.</td>
</tr>
<tr>
<td>14020172</td>
<td>Create directory: 'd:\Windows\system32\Grub' error.</td>
</tr>
<tr>
<td>14020182</td>
<td>No suitable storage device found.</td>
</tr>
<tr>
<td>14020192</td>
<td>Cannot find partition on storage device.</td>
</tr>
<tr>
<td>14020202</td>
<td>Required file update.ini not found on writable.</td>
</tr>
<tr>
<td>14020212</td>
<td>Required parameters missing in update.ini.</td>
</tr>
<tr>
<td>14020222</td>
<td>None of the specified network interfaces could be configured.</td>
</tr>
<tr>
<td>14020232</td>
<td>Not enough space on the target partition.</td>
</tr>
<tr>
<td>14020242</td>
<td>The target partition is too large for the specified image.</td>
</tr>
<tr>
<td>14020252</td>
<td>Could not access the specified URL.</td>
</tr>
<tr>
<td>14020262</td>
<td>Streaming data to flash error.</td>
</tr>
<tr>
<td>Error Code</td>
<td>Description</td>
</tr>
<tr>
<td>------------</td>
<td>-------------</td>
</tr>
<tr>
<td>14020302</td>
<td>Cloning error.</td>
</tr>
<tr>
<td>14020312</td>
<td>Failed to obtain return code from returned update file from cloning.</td>
</tr>
<tr>
<td>14020322</td>
<td>Failed to obtain return code from returned update file from cloning.</td>
</tr>
<tr>
<td>14020402</td>
<td>FTPException unknown error.</td>
</tr>
<tr>
<td>14020412</td>
<td>File or directory not found.</td>
</tr>
<tr>
<td>14020422</td>
<td>Get file error.</td>
</tr>
<tr>
<td>14020432</td>
<td>Read reply error.</td>
</tr>
<tr>
<td>14020442</td>
<td>Set PASV error.</td>
</tr>
<tr>
<td>14020452</td>
<td>Init reply error.</td>
</tr>
<tr>
<td>14020462</td>
<td>Change directory error.</td>
</tr>
<tr>
<td>14020472</td>
<td>Delete file error.</td>
</tr>
<tr>
<td>14020482</td>
<td>List directory error.</td>
</tr>
<tr>
<td>14020492</td>
<td>Get resume error.</td>
</tr>
<tr>
<td>14020502</td>
<td>User not accepted.</td>
</tr>
<tr>
<td>14020512</td>
<td>Password not accepted.</td>
</tr>
<tr>
<td>14020522</td>
<td>Create directory error.</td>
</tr>
<tr>
<td>14020532</td>
<td>Finish put error.</td>
</tr>
<tr>
<td>14020542</td>
<td>TypeI error.</td>
</tr>
<tr>
<td>14020552</td>
<td>Put file error.</td>
</tr>
<tr>
<td>14020562</td>
<td>Get finish error.</td>
</tr>
<tr>
<td>14020572</td>
<td>Remove directory error.</td>
</tr>
<tr>
<td>14020582</td>
<td>FTP quit error.</td>
</tr>
<tr>
<td>14020592</td>
<td>PWD error.</td>
</tr>
</tbody>
</table>
## Error Code Reference

<table>
<thead>
<tr>
<th>Error Code</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>14020602</td>
<td>Connect error.</td>
</tr>
<tr>
<td>14020612</td>
<td>Put resume error.</td>
</tr>
<tr>
<td>14020622</td>
<td>Set port error.</td>
</tr>
<tr>
<td>14020632</td>
<td>Unknown.</td>
</tr>
<tr>
<td>14020672</td>
<td>FileException unknown Exception.</td>
</tr>
<tr>
<td>14020712</td>
<td>File does not exist.</td>
</tr>
<tr>
<td>14020732</td>
<td>No more free disk space.</td>
</tr>
<tr>
<td>14020742</td>
<td>Write forbidden.</td>
</tr>
<tr>
<td>14020752</td>
<td>Create forbidden.</td>
</tr>
<tr>
<td>14020762</td>
<td>Read forbidden.</td>
</tr>
<tr>
<td>14020772</td>
<td>Create directory forbidden.</td>
</tr>
<tr>
<td>14020782</td>
<td>File seek forbidden</td>
</tr>
<tr>
<td>14020792</td>
<td>Combine path error.</td>
</tr>
<tr>
<td>14020812</td>
<td>MFC initialization failed.</td>
</tr>
<tr>
<td>14020822</td>
<td>Invalid parameter number.</td>
</tr>
<tr>
<td>14020832</td>
<td>Failed to retrieve .2do file.</td>
</tr>
<tr>
<td>14020842</td>
<td>Failed to open .2do file.</td>
</tr>
<tr>
<td>14020852</td>
<td>Zero length for the .2do file.</td>
</tr>
<tr>
<td>14020862</td>
<td>Ack not received.</td>
</tr>
<tr>
<td>14020872</td>
<td>CMD failed.</td>
</tr>
<tr>
<td>14020882</td>
<td>Reboot requested.</td>
</tr>
<tr>
<td>14020892</td>
<td>The result file was not created or cannot be opened.</td>
</tr>
<tr>
<td>14021001</td>
<td>Bad command line.</td>
</tr>
<tr>
<td>14021002</td>
<td>Invalid file path name.</td>
</tr>
<tr>
<td>Error Code</td>
<td>Description</td>
</tr>
<tr>
<td>-------------</td>
<td>--------------------------------------------------</td>
</tr>
<tr>
<td>14021003</td>
<td>Cannot create file.</td>
</tr>
<tr>
<td>14021004</td>
<td>Cannot run programs.</td>
</tr>
<tr>
<td>14021007</td>
<td>Cannot get platform type.</td>
</tr>
<tr>
<td>14021008</td>
<td>Cannot allocate memory.</td>
</tr>
<tr>
<td>14021009</td>
<td>Cannot get FTP address from registry.</td>
</tr>
<tr>
<td>14021010</td>
<td>Cannot set platform type.</td>
</tr>
<tr>
<td>14021011</td>
<td>Invalid parameter.</td>
</tr>
<tr>
<td>14021012</td>
<td>Cannot open existing file.</td>
</tr>
<tr>
<td>14021013</td>
<td>Time out to wait for a thread.</td>
</tr>
<tr>
<td>14021014</td>
<td>File size read does not match its actual size.</td>
</tr>
<tr>
<td>14021015</td>
<td>Cannot crack FTP URL.</td>
</tr>
<tr>
<td>14021016</td>
<td>Server not using FTP.</td>
</tr>
<tr>
<td>14021017</td>
<td>Connection open failed.</td>
</tr>
<tr>
<td>14021018</td>
<td>Cannot connect to server.</td>
</tr>
<tr>
<td>14021019</td>
<td>No file found on server.</td>
</tr>
<tr>
<td>14021020</td>
<td>No available space on storage media to copy a file.</td>
</tr>
<tr>
<td>14021021</td>
<td>There is an error when running NetCopy command.</td>
</tr>
<tr>
<td>14021022</td>
<td>There is an error when running SafeNetCopy command.</td>
</tr>
<tr>
<td>14021023</td>
<td>There is an error when running general command.</td>
</tr>
<tr>
<td>14021024</td>
<td>Cannot get an exit code of a process.</td>
</tr>
<tr>
<td>14021025</td>
<td>Get unexpected exit code of a thread.</td>
</tr>
<tr>
<td>14021026</td>
<td>Cannot get file size.</td>
</tr>
<tr>
<td>14021027</td>
<td>Cannot read content from file.</td>
</tr>
<tr>
<td>14021028</td>
<td>Failed to convert string from ASCII to Unicode.</td>
</tr>
<tr>
<td>Error Code</td>
<td>Description</td>
</tr>
<tr>
<td>------------</td>
<td>--------------------------------------------------</td>
</tr>
<tr>
<td>14021029</td>
<td>Cannot get file size.</td>
</tr>
<tr>
<td>14021030</td>
<td>Cannot rename file.</td>
</tr>
<tr>
<td>14021031</td>
<td>Cannot create directory.</td>
</tr>
<tr>
<td>14021099</td>
<td>RST file not found. Unknown error.</td>
</tr>
<tr>
<td>14022011</td>
<td>File corrupted (checksum error).</td>
</tr>
<tr>
<td>14022012</td>
<td>Failed to install firmware file.</td>
</tr>
<tr>
<td>14022013</td>
<td>Failed to install IPKG.</td>
</tr>
<tr>
<td>14022014</td>
<td>Failed to remove IPKG.</td>
</tr>
<tr>
<td>14022015</td>
<td>Unsupported format.</td>
</tr>
<tr>
<td>14022016</td>
<td>Not ready.</td>
</tr>
<tr>
<td>14022017</td>
<td>Not enough free disk space.</td>
</tr>
<tr>
<td>14022018</td>
<td>No such IPKG.</td>
</tr>
<tr>
<td>14022019</td>
<td>No such URL.</td>
</tr>
<tr>
<td>14022020</td>
<td>Failed to set registry.</td>
</tr>
<tr>
<td>14022021</td>
<td>Invalid parameter.</td>
</tr>
<tr>
<td>14022022</td>
<td>Remount error.</td>
</tr>
<tr>
<td>14022023</td>
<td>No such file.</td>
</tr>
<tr>
<td>14022024</td>
<td>No such path.</td>
</tr>
<tr>
<td>-2</td>
<td>Target agent timed out while executing task.</td>
</tr>
<tr>
<td>-100</td>
<td>Failed to get hostname.</td>
</tr>
<tr>
<td>-101</td>
<td>Hostname without domain part.</td>
</tr>
<tr>
<td>-102</td>
<td>Failed to set linger for socket.</td>
</tr>
<tr>
<td>-103</td>
<td>Reserved, no use.</td>
</tr>
<tr>
<td>-104</td>
<td>Reserved, no use.</td>
</tr>
</tbody>
</table>
## Error Code Reference

<table>
<thead>
<tr>
<th>Error Code</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>-105</td>
<td>Failed to get host address.</td>
</tr>
<tr>
<td>-106</td>
<td>Failed to create data socket.</td>
</tr>
<tr>
<td>-107</td>
<td>Failed to duplicate a socket.</td>
</tr>
<tr>
<td>-108</td>
<td>Failed to open file for read.</td>
</tr>
<tr>
<td>-109</td>
<td>Failed to open file for write.</td>
</tr>
<tr>
<td>-110</td>
<td>Failed to get socket name.</td>
</tr>
<tr>
<td>-111</td>
<td>Failed to bind data socket.</td>
</tr>
<tr>
<td>-112</td>
<td>Failed to bind data socket.</td>
</tr>
<tr>
<td>-113</td>
<td>Failed to listen on data socket.</td>
</tr>
<tr>
<td>-114</td>
<td>Server sent a invalid port number.</td>
</tr>
<tr>
<td>-115</td>
<td>Failed to connect to data socket.</td>
</tr>
<tr>
<td>-116</td>
<td>Failed to accept on data socket.</td>
</tr>
<tr>
<td>-117</td>
<td>Failed to set start point for file.</td>
</tr>
<tr>
<td>-118</td>
<td>Misc error for connection.</td>
</tr>
<tr>
<td>-119</td>
<td>Failed to retry connection.</td>
</tr>
<tr>
<td>-120</td>
<td>Connection is refused by peer.</td>
</tr>
<tr>
<td>-121</td>
<td>Bad transfer type.</td>
</tr>
<tr>
<td>-122</td>
<td>Invalid parameter for dir command.</td>
</tr>
<tr>
<td>-123</td>
<td>Failed to malloc memory.</td>
</tr>
<tr>
<td>-124</td>
<td>PWD command failed.</td>
</tr>
<tr>
<td>-125</td>
<td>CWD command failed.</td>
</tr>
<tr>
<td>-126</td>
<td>RMD command failed.</td>
</tr>
<tr>
<td>-127</td>
<td>Line list is bad.</td>
</tr>
<tr>
<td>-128</td>
<td>Option is not implemented.</td>
</tr>
<tr>
<td>Error Code</td>
<td>Description</td>
</tr>
<tr>
<td>------------</td>
<td>----------------------------------</td>
</tr>
<tr>
<td>-129</td>
<td>Function is not implemented.</td>
</tr>
<tr>
<td>-130</td>
<td>LIST command failed.</td>
</tr>
<tr>
<td>-131</td>
<td>RETR command failed.</td>
</tr>
<tr>
<td>-132</td>
<td>STOR command failed.</td>
</tr>
<tr>
<td>-133</td>
<td>Failed to write file.</td>
</tr>
<tr>
<td>-134</td>
<td>Failed to read file.</td>
</tr>
<tr>
<td>-135</td>
<td>Failed to write to socket.</td>
</tr>
<tr>
<td>-136</td>
<td>Failed to read from socket.</td>
</tr>
<tr>
<td>-137</td>
<td>Failed to open file.</td>
</tr>
<tr>
<td>-138</td>
<td>Bad magic code.</td>
</tr>
<tr>
<td>-139</td>
<td>Bad parameter.</td>
</tr>
<tr>
<td>-140</td>
<td>Failed to create directory.</td>
</tr>
<tr>
<td>-141</td>
<td>Cannot go to previous directory.</td>
</tr>
<tr>
<td>-142</td>
<td>Failed to chmod.</td>
</tr>
<tr>
<td>-143</td>
<td>Failed to umask.</td>
</tr>
<tr>
<td>-144</td>
<td>DELETE command failed.</td>
</tr>
<tr>
<td>-145</td>
<td>SIZE command failed.</td>
</tr>
<tr>
<td>-146</td>
<td>MDTM command failed.</td>
</tr>
<tr>
<td>-147</td>
<td>TYPE command failed.</td>
</tr>
<tr>
<td>-148</td>
<td>SIZE command is not available.</td>
</tr>
<tr>
<td>-149</td>
<td>MDTM command is not available.</td>
</tr>
<tr>
<td>-150</td>
<td>Failed to rename.</td>
</tr>
<tr>
<td>-151</td>
<td>Glob is failed.</td>
</tr>
<tr>
<td>-152</td>
<td>Failed to set keepalive.</td>
</tr>
<tr>
<td>Error Code</td>
<td>Description</td>
</tr>
<tr>
<td>------------</td>
<td>--------------------------------------------------</td>
</tr>
<tr>
<td>-153</td>
<td>Disconnected by FTP server when login in.</td>
</tr>
<tr>
<td>-154</td>
<td>Invalid user.</td>
</tr>
<tr>
<td>-155</td>
<td>Invalid password.</td>
</tr>
<tr>
<td>-156</td>
<td>Failed to login.</td>
</tr>
<tr>
<td>-157</td>
<td>Invalid relay from server.</td>
</tr>
<tr>
<td>-158</td>
<td>Connection is closed by peer.</td>
</tr>
<tr>
<td>-159</td>
<td>Not connected.</td>
</tr>
<tr>
<td>-160</td>
<td>Cannot start data transfer.</td>
</tr>
<tr>
<td>-161</td>
<td>Failed to transfer data.</td>
</tr>
<tr>
<td>-162</td>
<td>PORT command failed.</td>
</tr>
<tr>
<td>-163</td>
<td>PASV command failed.</td>
</tr>
<tr>
<td>-164</td>
<td>UTIME command failed.</td>
</tr>
<tr>
<td>-165</td>
<td>UTIME command is not available.</td>
</tr>
<tr>
<td>-166</td>
<td>HELP command failed.</td>
</tr>
<tr>
<td>-167</td>
<td>Failed to delete local file.</td>
</tr>
<tr>
<td>-168</td>
<td>Failed to seek local file.</td>
</tr>
<tr>
<td>-169</td>
<td>Data transfer is aborted.</td>
</tr>
<tr>
<td>-170</td>
<td>Symbol link is failed.</td>
</tr>
<tr>
<td>-171</td>
<td>Symbol link is not available.</td>
</tr>
<tr>
<td>-172</td>
<td>Glob is not match.</td>
</tr>
<tr>
<td>-173</td>
<td>FEAT command is not available.</td>
</tr>
<tr>
<td>-174</td>
<td>Specified file is not found.</td>
</tr>
<tr>
<td>-175</td>
<td>No buffer.</td>
</tr>
<tr>
<td>-176</td>
<td>Local file is newer.</td>
</tr>
<tr>
<td>Error Code</td>
<td>Description</td>
</tr>
<tr>
<td>------------</td>
<td>--------------------------------------------------</td>
</tr>
<tr>
<td>-177</td>
<td>Remote file is newer.</td>
</tr>
<tr>
<td>-178</td>
<td>Local file is same as the remote file.</td>
</tr>
<tr>
<td>-179</td>
<td>LSD command failed.</td>
</tr>
<tr>
<td>-180</td>
<td>MLST command failed.</td>
</tr>
<tr>
<td>-181</td>
<td>Invalid response for MLST command.</td>
</tr>
<tr>
<td>-182</td>
<td>MLST command is not available.</td>
</tr>
<tr>
<td>-183</td>
<td>MLSD command is not available.</td>
</tr>
<tr>
<td>-184</td>
<td>STAT command failed.</td>
</tr>
<tr>
<td>-185</td>
<td>STAT for file command is not available.</td>
</tr>
<tr>
<td>-186</td>
<td>NLST command failed.</td>
</tr>
<tr>
<td>-187</td>
<td>NLST for file command is not available.</td>
</tr>
<tr>
<td>-188</td>
<td>No file or directory error.</td>
</tr>
<tr>
<td>-189</td>
<td>Cannot tell if file exists.</td>
</tr>
<tr>
<td>-190</td>
<td>File exists but cannot find the file type.</td>
</tr>
<tr>
<td>-191</td>
<td>Is not a directory.</td>
</tr>
<tr>
<td>-192</td>
<td>Recursion limit is reached.</td>
</tr>
<tr>
<td>-193</td>
<td>Control socket is timeout.</td>
</tr>
<tr>
<td>-194</td>
<td>Data socket is timeout.</td>
</tr>
<tr>
<td>-195</td>
<td>User canceled the FTP task.</td>
</tr>
<tr>
<td>-1000</td>
<td>Invalid XML format.</td>
</tr>
<tr>
<td>-1001</td>
<td>Invalid XML version.</td>
</tr>
<tr>
<td>-1002</td>
<td>Failure executing clone task.</td>
</tr>
<tr>
<td>-1003</td>
<td>Unknown task ID.</td>
</tr>
<tr>
<td>-1004</td>
<td>Unknown parameter.</td>
</tr>
<tr>
<td>Error Code</td>
<td>Description</td>
</tr>
<tr>
<td>------------</td>
<td>-------------------------------------------------</td>
</tr>
<tr>
<td>-1005</td>
<td>Unknown FTP parameter.</td>
</tr>
<tr>
<td>-1101</td>
<td>Failure setting display settings.</td>
</tr>
<tr>
<td>-1102</td>
<td>Failure setting DNS.</td>
</tr>
<tr>
<td>-1103</td>
<td>Failure setting default Gateway.</td>
</tr>
<tr>
<td>-1104</td>
<td>Failure setting host name.</td>
</tr>
<tr>
<td>-1105</td>
<td>Failure setting IP mask.</td>
</tr>
<tr>
<td>-1106</td>
<td>Failure setting IP address.</td>
</tr>
<tr>
<td>-1107</td>
<td>Failure setting DHCP server.</td>
</tr>
<tr>
<td>-1108</td>
<td>Failure getting display settings.</td>
</tr>
<tr>
<td>-1109</td>
<td>Failure getting DHCP server.</td>
</tr>
<tr>
<td>-1110</td>
<td>Failure getting IP address.</td>
</tr>
<tr>
<td>-1111</td>
<td>Failure getting IP mask.</td>
</tr>
<tr>
<td>-1112</td>
<td>Failure getting host name.</td>
</tr>
<tr>
<td>-1113</td>
<td>Failure getting default Gateway.</td>
</tr>
<tr>
<td>-1114</td>
<td>Failure getting DNS.</td>
</tr>
<tr>
<td>-1115</td>
<td>User not logged in.</td>
</tr>
<tr>
<td>-1229</td>
<td>Unknown registry parameter.</td>
</tr>
<tr>
<td>-1230</td>
<td>Failure executing task (command could not be executed).</td>
</tr>
<tr>
<td>-1231</td>
<td>Error in 'software' tag.</td>
</tr>
<tr>
<td>-1232</td>
<td>Unknown VNC parameter.</td>
</tr>
<tr>
<td>-1233</td>
<td>Unknown pause parameter.</td>
</tr>
<tr>
<td>-1234</td>
<td>Task canceled by user.</td>
</tr>
<tr>
<td>-1235</td>
<td>Error in registry value (registry value too long).</td>
</tr>
<tr>
<td>-1236</td>
<td>Failure getting registry value.</td>
</tr>
<tr>
<td>Error Code</td>
<td>Description</td>
</tr>
<tr>
<td>------------</td>
<td>-------------</td>
</tr>
<tr>
<td>-1237</td>
<td>Failure cloning registry (item too long).</td>
</tr>
<tr>
<td>-1301</td>
<td>Failure connecting to FTP Repository.</td>
</tr>
<tr>
<td>-1302</td>
<td>Unknown FTP error.</td>
</tr>
<tr>
<td>-1303</td>
<td>Failure looking for remote file or low space on local drive.</td>
</tr>
<tr>
<td>-1305</td>
<td>Failure looking for replace.exe.</td>
</tr>
<tr>
<td>-1401</td>
<td>Unknown FTP Error.</td>
</tr>
<tr>
<td>-1402</td>
<td>File or Directory not found.</td>
</tr>
<tr>
<td>-1403</td>
<td>Failed to get file.</td>
</tr>
<tr>
<td>-1404</td>
<td>Failed to receive reply from server.</td>
</tr>
<tr>
<td>-1405</td>
<td>Failed to set FTP mode PASV.</td>
</tr>
<tr>
<td>-1406</td>
<td>Server reply is invalid.</td>
</tr>
<tr>
<td>-1407</td>
<td>Failed to change current working directory.</td>
</tr>
<tr>
<td>-1408</td>
<td>Failed to delete file.</td>
</tr>
<tr>
<td>-1409</td>
<td>Failed to list directory.</td>
</tr>
<tr>
<td>-1410</td>
<td>Failed to resume getting a file.</td>
</tr>
<tr>
<td>-1411</td>
<td>User name error.</td>
</tr>
<tr>
<td>-1412</td>
<td>Password error.</td>
</tr>
<tr>
<td>-1413</td>
<td>Failed to create directory.</td>
</tr>
<tr>
<td>-1414</td>
<td>Failed to receive finish message about file is transferred.</td>
</tr>
<tr>
<td>-1415</td>
<td>Failed to set binary mode.</td>
</tr>
<tr>
<td>-1416</td>
<td>Failed to upload file.</td>
</tr>
<tr>
<td>-1417</td>
<td>No use.</td>
</tr>
<tr>
<td>-1418</td>
<td>Failed to remove directory.</td>
</tr>
<tr>
<td>-1419</td>
<td>Failed to receive QUIT reply from FTP server.</td>
</tr>
<tr>
<td>Error Code</td>
<td>Description</td>
</tr>
<tr>
<td>------------</td>
<td>-------------</td>
</tr>
<tr>
<td>-1420</td>
<td>Failed to receive PWD reply from FTP server.</td>
</tr>
<tr>
<td>-1421</td>
<td>Failed to connect to FTP server.</td>
</tr>
<tr>
<td>-1422</td>
<td>Failed to resume uploading a file.</td>
</tr>
<tr>
<td>-1501</td>
<td>Unknown FTP file error.</td>
</tr>
<tr>
<td>-1502</td>
<td>File does not exist.</td>
</tr>
<tr>
<td>-1503</td>
<td>No more disk space.</td>
</tr>
<tr>
<td>-1504</td>
<td>Failed to open a file for write.</td>
</tr>
<tr>
<td>-1505</td>
<td>Failed to create a new file.</td>
</tr>
<tr>
<td>-1506</td>
<td>Failed to open a file for read.</td>
</tr>
<tr>
<td>-1507</td>
<td>Failed to create a directory.</td>
</tr>
<tr>
<td>-1508</td>
<td>Failed to seek a resumption point.</td>
</tr>
<tr>
<td>-1509</td>
<td>Failed to combine file path.</td>
</tr>
<tr>
<td>-2001</td>
<td>Error in configuration file.</td>
</tr>
<tr>
<td>-2002</td>
<td>Error in configuration file (invalid format).</td>
</tr>
<tr>
<td>-2003</td>
<td>Error in configuration file (no group).</td>
</tr>
<tr>
<td>-2004</td>
<td>Error in configuration file (no item).</td>
</tr>
<tr>
<td>-2005</td>
<td>Invalid name format.</td>
</tr>
<tr>
<td>-2006</td>
<td>Invalid task content.</td>
</tr>
<tr>
<td>-2007</td>
<td>Failure executing file (error executing after reboot).</td>
</tr>
<tr>
<td>-2008</td>
<td>Failure opening VNC password file.</td>
</tr>
<tr>
<td>-2009</td>
<td>Failure setting VNC password.</td>
</tr>
<tr>
<td>-2010</td>
<td>Failure connecting to configuration daemon.</td>
</tr>
<tr>
<td>-2011</td>
<td>Failure sending task to configuration daemon.</td>
</tr>
<tr>
<td>-2012</td>
<td>Configuration daemon message timeout.</td>
</tr>
<tr>
<td>Error Code</td>
<td>Description</td>
</tr>
<tr>
<td>------------</td>
<td>-------------</td>
</tr>
<tr>
<td>-2013</td>
<td>Configuration daemon failure.</td>
</tr>
<tr>
<td>-2014</td>
<td>Update cannot be executed, an upgrade task is currently running.</td>
</tr>
<tr>
<td>-2015</td>
<td>Failure getting update information from setup.conf.</td>
</tr>
<tr>
<td>-2016</td>
<td>Network connection failure.</td>
</tr>
<tr>
<td>-2018</td>
<td>Update cannot be executed, incorrect patch version.</td>
</tr>
<tr>
<td>-2019</td>
<td>Update successful. Caution: TO_VERSION info in .hdr file differs from the /etc/.maxspeed.</td>
</tr>
<tr>
<td>-2020</td>
<td>Failure getting *.pch file or not enough disk space.</td>
</tr>
<tr>
<td>-5000</td>
<td>Failure accessing registry (blank path).</td>
</tr>
<tr>
<td>-5001</td>
<td>Failure accessing registry (invalid path).</td>
</tr>
<tr>
<td>-5002</td>
<td>Failure accessing registry (could not open current user).</td>
</tr>
<tr>
<td>-5003</td>
<td>Failure accessing registry (item does not exist).</td>
</tr>
<tr>
<td>-5004</td>
<td>Failure accessing registry (invalid value type).</td>
</tr>
<tr>
<td>-5005</td>
<td>Failure accessing registry (error opening key).</td>
</tr>
<tr>
<td>-5006</td>
<td>Failure accessing registry (error enumerating value).</td>
</tr>
<tr>
<td>-10001</td>
<td>The task type is unrecognized by the Gateway.</td>
</tr>
<tr>
<td>-10002</td>
<td>The task format is unrecognized by the Gateway.</td>
</tr>
<tr>
<td>-10003</td>
<td>The IP range is invalid.</td>
</tr>
<tr>
<td>-20001</td>
<td>Timed out while waiting for task result from target agent.</td>
</tr>
<tr>
<td>-20002</td>
<td>Task failed. Task became invalid before being sent. Task failed. Management Gateway cannot be connected, and no retry setting.</td>
</tr>
<tr>
<td>-20003</td>
<td>Could not connect with target Gateway.</td>
</tr>
<tr>
<td>-20004</td>
<td>Could not find target Gateway.</td>
</tr>
</tbody>
</table>
## Error Code Reference

<table>
<thead>
<tr>
<th>Error Code</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>-20005</td>
<td>A device with the same MAC address already exists.</td>
</tr>
<tr>
<td>-20006</td>
<td>A grouping scheme with the same alias already exists.</td>
</tr>
<tr>
<td>-20007</td>
<td>An IP walking scopes with the same name already exists.</td>
</tr>
<tr>
<td>-20008</td>
<td>A user with the same name already exists.</td>
</tr>
<tr>
<td>-20009</td>
<td>A user group with the same name already exists.</td>
</tr>
<tr>
<td>-20010</td>
<td>An FTP Repository with the same name already exists.</td>
</tr>
<tr>
<td>-20011</td>
<td>Fail to send task because Management Server cannot get acknowledge from the Management Gateway.</td>
</tr>
<tr>
<td>-20012</td>
<td>The target Management Gateway is not authenticated by the Management Server.</td>
</tr>
<tr>
<td>-20013</td>
<td>FTP setting is not correct for the FTP mapped by the device.</td>
</tr>
</tbody>
</table>
Index

A

add
  console user 177
  device using MAC address 173
  devices using Discover 45
agent templates
  configure agent 175
  update agent 176
agent.cfg configuration file 49
agents
  configuration file 49
  configure agent template 175
  discovering 45
    agent config file 49
    by DHCP tag 49
    walking with IP list 48
    walking with IP range 46
  gateway detection 45
  overview 3
  push/pull modes
    concept 6
    configuring 175
  system requirements 13
  update agent template 176
alias management
  device version 209
  exporting an alias 212
  importing an alias 212
  subnet address 211

authentication
  export all keys 198
  import key(s) 199
  key management 196
  key update 196
  key update log 200
  management 196

C

ChangeSID 152
clients
  see devices
  clone XPe image template 153
  command sub-task 134
    persistent write to / (NeoLinux 4.x) 170
  concepts 4
  configuration file
    agent 49
  configuration management
    exclude working hours 104, 192
    valid time and timeout 103, 191
    write filter policy setting 104, 192
  configure agent template 175
  configure registry sub-task dialog 164
  connection
    check status 87
    client settings 119
    device network status 87
    ping utility 87
Index

trace route utility 87
connection configuration template 119
console
   see Management Console
conventions used in manual 9
copy files sub-task 131

d delete files sub-task 128
deleting
   console users 178
devices 67
   repository 184
tasks 107
device filter 81
device management 64
Device Manager
   installing 11
   overview 1
   system structure 2
   uninstalling 34
device pane
   concept 4
   description 44
   using 64
device status tools 109
   status snapshot 114
   status walker 109
device toolbar
   overview 43
device tree
   concept 4
   icons displayed 65
   overview 44
   searching for a device 86
   using 64
devices
   adding using MAC address 173
   agent overview 3
   command execution 134
   connection status 87
   connections 119
deleting 67
discover by IP range 69
discover using IP list 69
discovering 68
displaying properties 66
grouping 71
   pre-assign from device 80
grouping properties 67
   limiting viewing by user 85
   listing FTP servers 186
   power management 93
   pre-assigning to groups 80
   printing properties 89
   reboot 93
   registry settings 159
   remote commands 134
   search for in device tree 86
   security filter 85
   shadowing 91
   shutdown 93
   status tools 109
   status snapshot 114
   status walker 109
task assignment 99
   wake on LAN 93
DHCP server
   configuration for PXE 30
   installation 33
   linux configuration 33
DHCP tag
   agent discovery 49
   discover
   agents 45
devices 45, 68
gateway 68
display
   settings template 123
task log 107
task properties 102
E
   elements
      concept 4
      importing into repository 52
      repository 39
Enhanced Write Filter
### Index

see EWF
- error codes 219
- EWF
  - concept 6
  - policy setting 104, 192
  - exclude working hours 104, 192
  - executing commands remotely 134
- export
  - alias 212
  - all authentication keys 198

**F**
- favorite templates 96
- file and registry template 127
  - command sub-task 134
    - NeoLinux 4.x devices 170
  - copy files sub-task 131
  - delete files sub-task 128
  - merging 130
  - pause sub-task 130
  - registry sub-task 159
- file and registry templates
  - get registry 159
- filters
  - editing device filter 81
  - limiting devices seen by user 85
  - security 85
- firewall settings 14
- frequently used templates 96
- FTP mappings 186
- FTP repository 51, 183, 184
  - adding elements to
    - elements
      - adding to repository 51
  - choosing 185
  - configuring 39
  - creating 39
  - description 39
  - importing element (snapin) 52
  - relay FTP server 51, 54
  - software components (XPe) 166
  - wizard 39
- FTP repository wizard 39
- FTP servers

### Listing

- for devices 186
- for subnets 187
- overview 3
- supported 13

**G**
- gateway
  - see Management Gateway
- get connection configuration 119
- grouping
  - candidate properties 72
  - console users 178
  - devices 71
  - pre-assign from device itself 80
  - properties 67, 72
    - changing 79
    - naming 78
  - property name 190
- groups
  - add users 177
  - adding 180, 182
  - assign users to 178
  - assigning permissions 180
  - properties 180
  - working with 180

**I**
- icons
  - device tree 65
  - in systray
    - gateway 29
    - server 29
  - Management Console on desktop 29
  - task pane 98
  - toolbar 62
- images
  - clone XPe device 153
  - importing & transferring in repository 145
  - introduction 145
  - pull PXE image from device 147
  - push PXE image to device 150
  - signing PXE images 146
Index

update image 157
using MAC address to push to client 173
verifying PXE images 146
XPe client preparation 152
images templates
  clone XPe image 153
  PXE imaging 147, 150
  update image 157
import
  alias 212
  authentication key 199
  license 195
  template plugin 213
installation
  administrator password 27
  DHCP server 33
  JRE (Java runtime environment) 215
  MySQL 217
  ports required 14
  PXE 33
  routers 33
  system requirements 12
  third-party software 13
  Windows-based servers 16
installing XPe software components 166, 169

J
Java runtime environment (JRE)
  installing & running 215
  software requirement 12, 20

K
key management 196
key update log 200

L
licensing 195
  import license 195
log-in 37

M
MAC address
  using to add device 173
managed device
concept 5
Management Console
  administration 177
  device pane 4, 44
  device toolbar
    overview 43, 62
  device tree 4, 44
  icon on desktop 29
  launching 37
  logging in 37
  menu item functions 57
  OS tabs 5
    overview 43
    overview 2, 43
  status bar 6
    overview 44
  summary pane 6
  system requirements 12
  task pane 6, 44, 98
    icons 98
  task templates
    pane 94
  template pane 6, 44
  template toolbar 44
    overview 63
  users 177
    adding 177
    assigning to groups 178
    deleting 178
    password change 179
  working with groups 180
Management Gateway
  agent detection 45
  automatic agent registration 49
controlling access 201
discovering 68
icon in systray 29
IP address
  agent config file 49
overview 3
router configuration 33
system requirements 13
Management Server
icon in systray 29
overview 3
system requirements 12
menu items in console 57
merging file and registry templates 130
MySQL 217

N
NeoLinux 4.x devices
  file system 170
  persistent write to / 170
network
  connection status 87
  ping utility 87
  requirements 14
  settings template 122
  trace route utility 87

O
operations templates
  reboot device 93
  shadow device 91
  shutdown device 93
  wake up device 93
OS tabs
  concept 5
  overview 43
overview
  agent 3
  FTP server 3
  Management Console 2, 43
  Management Gateway 3
  Management Server 3

P
password
  changing 179
  setting 178
  setting during installation 27
pause sub-task 130
pausing tasks 105
ping utility 87
ports required
  custom 14
standard 14
power management 93
pre-assigning devices to groups 80
printing
  device information 89
  task report 90
properties
  device 66
  grouping 66
  printing 89
PXE
  concept 5
  configuring DHCP server for 30
image
  signing 146
  verifying 146
installation 33
PXE imaging template 147, 150

R
reboot device template 93
registry
  changing settings 159
  configure registry sub-task dialog 162, 164
  editing key values 165
  editing settings 163
  file and registry template 163
  get registry template 159
  getting settings from a device 159
  key values 165
  task template 127
  template editor 162
  viewing settings 162, 164
registry sub-task 159
relay FTP server 51, 54
remote command execution 134
report
  adding report template 202
  generating 207
  importing report plug-in file 206
  management 202
repository
  adding elements to 51
  choosing 185
concept 5
configuring 39, 183, 184
creating 39
deleting 184
description 39
exporting 184
FTP repository wizard 39
FTP server support 13
importing 185
importing an element (snapin) 52
listing FTP servers 186, 187
relay FTP server 51, 54
repository management 51
snapins 138
software components (XPe) 166
transferring elements 51
repository management tool 51
resending tasks 106
results template 108
router configuration 33

S
search
  for device in device tree 86
toolbar button 86
search device dialog 86
security ID for XPe device 152
sequence template 96
server repository
  description 39
settings templates
  display 123
  network 122
  time 124
  write filter 125
shadow device template 91
shadowing devices 91
  VNC viewer 92
shutdown device 93
shutdown device template 93
snapins 137
  applying to devices 138
  importing into repository 52
  introduction 137
  obtaining 138
  repository management 138
  snapin template 142
software components (XPe)
  adding to repository 166
  installing 166, 169
software update templates
  snapin 142
  software component (XPe) 169
software updates 7
status bar
  concept 6
  overview 44
status snapshot 114
status walker 109, 194
subnet
  address alias 211
  listing FTP servers 187
summary pane 6
system requirements 12
agents 13
  FTP server 13
  Management Console 12
  Management Gateway 13
  Management Server 12
  network 14

task pane
  concept 6
  overview 44
task parameters 191, 193
task report
  printing 90
task settings 193
task templates
  agent 175
    configure agent 175
    update agent 176
categories 94
Index

concept 4
connections
  get connection configuration 119
creating 95
ingoing 95
exporting 97
favorites 96
file and registry
  file and registry 163
get registry 159
  using 127
frequently used 96
images
  clone XPe image 153
  PXE imaging 147, 150
  update image 157
importing 97
managing 94
merging file and registry templates 130
operations
  reboot device 93
  shadow device 91
  shutdown device 93
  wake up device 93
overview 94
pane in console 94
sequence 96
settings
  display 123
  network 122
  time 124
  write filter 125
software component (XPe) 169
software update
  snapin 142
  software component (XPe) 169
template sequence 96
tasks
  assign to devices 99
  concept 5
  continuing 106
  deleting 107
display log 107
displaying properties 102
exclude working hours 104, 192
file and registry template 127
log display 107
management 98
parameters 103, 191, 193
pausing 105
properties 102
report
  printing 90
resending 106
results template 108
sequence template 96
task pane 98
time and timeout 103, 191
VNC viewer 108
write filter policy setting 104, 192
TCP ports required 14
technical support 7
template pane
  concept 6
  overview 44
template plugin
  importing 213
  management 213
  removing 214
template toolbar
  overview 44
templates
  see task templates
terms used in manual 9
third-party software required 13
time and timeout 103, 191
time settings template 124
toolbar
  overview 62
  search button 86
trace route utility 87
transferring elements 51
troubleshooting 7

U
UDP ports required 14
Index

update agent template 176
update image template 157
user management 177

V
valid time and timeout 103, 191
VNC viewer 92
task 108

W
wake on LAN 93
wake up device template 93
walking tool 109
walking with IP list 48
walking with IP range 46
Windows scripts 136
WOL 93

working hours 104, 192
write filter
settings template 125
write filter policy setting 104, 192

X
XML file 94
export task template as 97
import as task template 97
XPe devices
ChangeSID 152
cloning images 153
software components
adding to repository 166
installing 166